Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#51690 closed defect (bug) (fixed)

Change "stati" to "statuses" in WP_Comment_Query::__construct() DocBlock

Reported by: collizo4sky's profile Collizo4sky Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: 5.6 Priority: normal
Severity: normal Version: 5.1
Component: Comments Keywords: has-patch
Focuses: docs Cc:

Attachments (2)

51690.diff (1.0 KB) - added by Presskopp 3 years ago.
51690.2.diff (1.0 KB) - added by Presskopp 3 years ago.

Download all attachments as: .zip

Change History (9)

3 years ago

3 years ago

#1 @Presskopp
3 years ago

  • Keywords has-patch added

the patch

#2 @davidbaumwald
3 years ago

  • Focuses docs added
  • Keywords 2nd-opinion added
  • Version set to 5.1

Is this an actual issue? stati is plural for status in WP Core, and the parameter accepts either a single status as a string or an array of multiple stati. Should this instead be changed to Comment status or stati...?

Originally changed to stati in [42165].

#3 @Collizo4sky
3 years ago

Never heard the word stati before. The plural of status is statuses.

#4 @SergeyBiryukov
3 years ago

  • Component changed from General to Comments
  • Keywords 2nd-opinion removed
  • Milestone changed from Awaiting Review to 5.6
  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing
  • Summary changed from Typo fix in docbloc to Rename "stati" to "statuses"

Thanks for the patch!

Looking at some online sources, it seems like "statuses" is indeed the preferred form here.

It also seems to be the only instance of "stati" in core, whereas "statuses" appears in 34 files.

Last edited 3 years ago by SergeyBiryukov (previous) (diff)

#5 @SergeyBiryukov
3 years ago

  • Type changed from enhancement to defect (bug)

#6 @SergeyBiryukov
3 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 49472:

Docs: Use a consistent plural form of "status".

Props Collizo4sky, Presskopp, davidbaumwald.
Fixes #51690.

#7 @SergeyBiryukov
3 years ago

  • Summary changed from Rename "stati" to "statuses" to Change "stati" to "statuses" in WP_Comment_Query::__construct() DocBlock
Note: See TracTickets for help on using tickets.