WordPress.org

Make WordPress Core

Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#51718 closed defect (bug) (invalid)

The new XML sitemaps functionality in WordPress 5.5 did not work if Plain is selected in Permalink Settings

Reported by: bfallert Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.5
Component: Sitemaps Keywords:
Focuses: Cc:

Description

The new XML sitemaps functionality in WordPress 5.5 did not work if "Plain" is selected in Permalink Settings.

If i changed in a test blog this settings to "Day and name" the new XML sitemaps is working. If i changed it back to "Plain" it stops again.

Change History (5)

#1 @johnbillion
13 months ago

  • Version changed from trunk to 5.5

#2 @swissspidy
13 months ago

  • Keywords reporter-feedback added; needs-patch removed

If you are using plain permalinks, you can access the sitemap via example.com/?sitemap=index.

When using pretty permalinks, you can access it via example.com/wp-sitemap.xml.

That is expected behavior.

Can you confirm that accessing the sitemap via example.com/?sitemap=index works for you?

#3 @bfallert
13 months ago

Yes I can confirm that.
I did not find this information in the documentation. Thank you for this helpful tip!
For me the problem is solved!

#4 @bfallert
13 months ago

Yes I can confirm that.
I did not find this information in the documentation. Thank you for this helpful tip!
For me the problem is solved!

#5 @johnbillion
13 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

@bfallert Thanks for confirming! You can also find this link in the robots.txt file on your site, which is how search engines find the correct link. Example: https://johnblackbourn.com/robots.txt

Version 0, edited 13 months ago by johnbillion (next)
Note: See TracTickets for help on using tickets.