Make WordPress Core

Changes between Version 3 and Version 4 of Ticket #51742, comment 13


Ignore:
Timestamp:
11/11/2020 08:57:25 AM (15 months ago)
Author:
azaozz
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #51742, comment 13

    v3 v4  
    551. The `$major_optin_disabled = false;` var is a "double negative". Perhaps would be easier to read/understand if it was a "positive", i.e. `$major_optin_enabled = true;`? Also the name could be a bit more descriptive, perhaps, like `$upgrade_major_optin_enabled` or similar.
    66
    7 2. The `$is_major_optin_disabled` doesn't seem needed? If there should be a specific filter for disabling major core updates that runs in addition to `$upgrade_major = apply_filters( 'allow_major_auto_core_updates', $upgrade_major );`, it can perhaps be checked right in the conditional (and expect only boolean `true`).
     72. The `$is_major_optin_disabled` doesn't seem needed? If there should be a specific filter for disabling major core updates that runs in addition to `$upgrade_major = apply_filters( 'allow_major_auto_core_updates', ...`, it can perhaps be checked right in the conditional (and expect only boolean `true`).
    88
    993. Perhaps `do_action( 'after_core_auto_updates_settings_fields', $auto_update_settings );` can be only `after_core_auto_updates_settings` as there aren't any "fields" there.