WordPress.org

Make WordPress Core

#51821 closed feature request (duplicate)

Make starter content available for non-"fresh sites"

Reported by: helen Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Customize Keywords:
Focuses: Cc:

Description

Starter content is currently restricted for use on sites that are considered "fresh" (see #38114 for history), typically new installs that haven't changed any content yet. This is a pretty limited scenario, as users frequently try editing the default content before heading into the customizer or anything else (related: #51820), and there are plenty of scenarios in which some content has been added but it's still early enough that starter content for a theme might be helpful.

It was always intended for starter content to evolve into something more broadly applicable, and with the theme previewer site approaching a point where starter content can be used for demo purposes along with blocks and block patterns in the core editor, now is a good time to start figuring out what kind of experience existing sites should have around starter content, from letting the user know that starter is available to how it's applied (perhaps selectively) to managing or undoing those changes.

Change History (1)

#1 @helen
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #38624.

Note: See TracTickets for help on using tickets.