WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 4 months ago

#51834 closed defect (bug) (invalid)

I18N - Translations of Twenty-Twentyne are not shown & adjustments

Reported by: transl8or Owned by:
Milestone: Priority: normal
Severity: minor Version: 5.6
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

1) No automatic delivery of translation files

I just installed manually - by downloading the .mo/.po-files from the translate.w.org repository - the german translations for formal and informal german.
They are currently not delivered automatically to a fresh installed test enviroment with WordPress 5.6 RC1.
The german translations of the Twenty Twenty-One theme are already over 90%.

@ocean90 Is the automatic delivery meant to happen later or is this an issue with the servers or Glotpress at the moment?

(I ask because I also have a 5.5 network installation (WP multisite) running for testing issues with various themes and within that the description text of the themes are also not shown in german, even thought all the themes and the description texts are 100% translated.)

2) Two strings of the translation files differ from the shown ones

They are under Colors & Dark Mode and below the checkmark box. They are not shown as translated and they differ with the strings on the code on github abit.

We have the string
"Respect visitor&#8217;s device dark mode settings.<br>Dark mode is a device setting. If a visitor to your site requests it, your site will be shown with a dark background and light text.<br><br>Dark Mode can also be turned on and off with a button that you can find in the bottom right corner of the page."
but it links to:
https://github.com/WordPress/twentytwentyone/blob/trunk/classes/class-twenty-twenty-one-dark-mode.php#L169 and there it is shorter:
"Dark Mode is a device setting. If a visitor to your site requests it, your site will be shown with a dark background and light text. <a href="%s">Learn more about Dark Mode."

I can add a screenshot.

3) String improvements to have shorter & more appropriate translation terms

a) Can the string "Dark Mode Support" be changed to "Enable Dark Mode"?

That's a more common wording beneath a checkmark box in most of the themes I've contributed to.
Another point is that a translation in german is a quite uncommon veeery long word like:

"Dark-Mode-Unterstützung" witch sounds really strange.
Or in dutch it's quite long too: "Donkere modus ondersteuning"

b) Can the string for the color "Orange" be changed to "Beige"?

I've seen that the color comes from the orange color range, but it does not really look "Orange", especially on a white background like it is used in the About page. Okay, on the pastel green background it looks more orange-like but on all the others ...

I would find it more accurate to name it "Beige" because it looks so on most screens and backgrounds, except the default sagegreen one. I would expect a color like #ffa500 for orange or in the context of pastel orange #ffb347.

Will add screenshots (later) too.

Attachments (6)

2021-Theme-withStrings-whoseTranslations-do-not-show-AndOrangeColorVariations-OnAntiquePink.png (113.0 KB) - added by transl8or 5 months ago.
TwentyTwentyOne-Theme with strings whose translations do not show, on the left side with red border
Orange-Color-Variaus-VS-Beige-in-TwentyTwentyOne-Theme.png (75.3 KB) - added by transl8or 5 months ago.
Orange or Beige - various color variations with TwentyTwentyOne
Orange-Color-Variaus-VS-Beige-in-TwentyTwentyOne-Theme2.png (87.3 KB) - added by transl8or 5 months ago.
Orange or Beige 2 - various color variations with TwentyTwentyOne
Searchform_TwentyTwentyOne-Theme.png (24.9 KB) - added by transl8or 5 months ago.
Searchform-titel-with-hellip_YES-or-NO_TwentyTwentyOne-Theme.png (28.1 KB) - added by transl8or 5 months ago.
Searchform-on-Mobile_betterBold-or-nothing-at-all_TwentyTwentyOne-Theme.png (24.8 KB) - added by transl8or 5 months ago.

Download all attachments as: .zip

Change History (22)

@transl8or
5 months ago

TwentyTwentyOne-Theme with strings whose translations do not show, on the left side with red border

@transl8or
5 months ago

Orange or Beige - various color variations with TwentyTwentyOne

#1 follow-up: @ocean90
5 months ago

The new originals have been updated a few minutes ago and can now be translated. Language packs are automatically shipped once the theme is published in the Theme Directory.

@transl8or
5 months ago

Orange or Beige 2 - various color variations with TwentyTwentyOne

#2 in reply to: ↑ 1 @transl8or
5 months ago

Replying to ocean90:

The new originals have been updated a few minutes ago and can now be translated. Language packs are automatically shipped once the theme is published in the Theme Directory.

Great! Thanks a lot @ocean90 :-)

#3 @transl8or
5 months ago

There are two more translation strings in Twenty Twenty-One that could be changed imho:

"Media and text article title"
here: https://build.trac.wordpress.org/browser/branches/5.6/wp-content/themes/twentytwentyone/inc/block-patterns.php?marks=56#L56
seems better with something like: "Picture with title and text".

And the string "Search&hellip" above the search form
here: https://build.trac.wordpress.org/browser/branches/5.6/wp-content/themes/twentytwentyone/searchform.php?marks=24#L24
looks different in it's styling compared with the other widgets. The text is not bold and the hellip is not typical in that place.
I wonder if it is necessary there at all, because if someone wants some text above the search form they could add a custom title in the widget. And the problem is if you add just the "Search" (or something else) as a title via the widget you have it double and a the word "Search" a third time on the button, which looks odd.

#4 @transl8or
5 months ago

Here are screenshots of the searchform with the string "Search&hellip" that comes from the theme.
And how it looks like with a title added from the widget.
IMHO It could look much cleaner and more modern without the not-bold fixed text string with hellip. Even or especially on small mobile screens.

Last edited 5 months ago by transl8or (previous) (diff)

#5 follow-up: @poena
5 months ago

Hi!

For 3 a,

a) Can the string "Dark Mode Support" be changed to "Enable Dark Mode"?

This string was carefully chosen and the team decided against using "Enable Dark Mode" because it is not what the setting does. It would not be an accurate description.

The feature enables support for the device setting, and it enables the toggle button.

The team had long discussions back and forward about this, and the reasoning is public and documented on the themes GitHub repository.

I have already replied about the color names in the issue that was opened on the themes Github repository.
We do not plan to change the color names.

The design for the search widget is a separate issue, but this is intended and as per the themes design.

It is not only a design choice, the form must have a label. Yes it is necessary both when the widget title is hidden and when a widget title is added.

#6 @transl8or
5 months ago

Hello @poena,

thanks for your reply. Going to accept your decision concerning the color names.
(It's just that I have experienced various arguments between a designer team and a project lead in the past and after some mediation from the a third party it turned out the project lead was "red-green-colorblind". The designers then became more accurate in that company and the project lead less destructive with his feedback to the designers.)

What do you think about a correction of the string "Media and text article title" which I have mentions in https://core.trac.wordpress.org/ticket/51834#comment:3

And the last string improvement I would suggest (at the end of the theme translation fine tunning) is the title of the picture "La Lecture" (original french title of it) which was translated as "Reading" and has no comment.
here: https://build.trac.wordpress.org/browser/branches/5.6/wp-content/themes/twentytwentyone/inc/block-patterns.php?marks=107#L107 and
here: https://build.trac.wordpress.org/browser/branches/5.6/wp-content/themes/twentytwentyone/inc/block-patterns.php?marks=107#L107
There are some languages that actually contribute to that tiny difference in the words.
The swedish dictionary told me there is the word "lektyr" which seems to be the better choice, as it probably (like in german) can refer to both: to the process of reading and to the read object itself. Adding the orignal french title in a comment could help translators.
I think the english word "Reading" does only describe the proccess of reading and a lecture is more of a lessons in the context of teaching something in schools or so.

And last but not least.
So the only way to have only one bold title like "Search" (as a noun) above the searchform is to remove the hard coded "Search&hellip" or make it bold via a custom CSS hack.
Got it. Thanks.

#7 @poena
5 months ago

I would absolutely not recommend any user to remove the label from the search widget field, that would have negative accessibility impacts for users.

#8 follow-up: @poena
5 months ago

As I have already explained the string freeze for the theme was at beta 4, and we are now approaching release candidate two.

The translator comment or context for "Reading" would not be a change of the string itself, so this is something that we could improve.

#9 in reply to: ↑ 8 @transl8or
5 months ago

  • Severity changed from normal to minor

Replying to poena:

As I have already explained the string freeze for the theme was at beta 4, and we are now approaching release candidate two.

It's all good and I know about the dates in a/this release cirlce. Meaning, I'm used to last minute changes in translation strings and comments even after string freezef or the aprox. last 10 releases. Really looking forward to the next RC and the new/improved strings from the About page and TT1. :)
I don't mind changes at the very end and things get improved for all participants.

#10 @transl8or
5 months ago

The translator comment or context for "Reading" would not be a change of the string itself, so this is something that we could improve.

=> comment on string: original french title of painting: La Lecture

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


5 months ago

#12 in reply to: ↑ 5 @transl8or
5 months ago

  • Summary changed from I18N - Translations of Twenty-Twentyone are not shown & adjustments to I18N - Translations of Twenty-Twentyne are not shown & adjustments

Replying to poena:

The design for the search widget is a separate issue, but this is intended and as per the themes design.

It is not only a design choice, the form must have a label. Yes it is necessary both when the widget title is hidden and when a widget title is added.

@poena Sorry for bringing that up again.
Is it really a design choice to have the translatable string "Search&hellip" above the search form? After looking through almost all default-themes from the last years I realized that this string was always (in light grey) a placeholder IN the searchform. Not above it.
That's what puzzled me and I probably communicated it here in the wrong way.

Anyways, I'll let it up to you @poena to bring this issue to github or trac for version 1.1 of TT1 or just close it here because it's to minor (for the coming release) or missunderstood from my side. Thank's a lot.

#13 @poena
5 months ago

Hi

The text is inside a label, this label is used to identify the input field in the form.
A placeholder can not be a replacement for a label and the accessibility team recommends that labels are visible.
https://make.wordpress.org/themes/handbook/review/accessibility/required/#forms
https://make.wordpress.org/accessibility/handbook/best-practices/quick-start-guide/#forms

#14 @poena
4 months ago

@transl8or Hi! Have you been able to confirm if the first point, about the automatic delivery of translation files has been solved for you?

#15 @transl8or
4 months ago

@poena Hey, and yes the automatic delivery works fine now since the release on Tuesday :)
[ It also works like a charm now for all the other default themes (2011, 2012, 2013, 2016, 2017, 2019, 2020) that received new strings yesterday and temporarily fell under 90%. ]

#16 @poena
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Sounds good, then let's close this one.

Note: See TracTickets for help on using tickets.