WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 7 weeks ago

#51886 closed defect (bug) (fixed)

Dashboard - Activity: Latest comments row actions links on focus

Reported by: kebbet Owned by: SergeyBiryukov
Milestone: 5.6 Priority: normal
Severity: normal Version: 5.6
Component: Administration Keywords: has-patch has-screenshots commit dev-reviewed
Focuses: ui, accessibility, javascript, css Cc:

Description

In 5.5.3 the action links in the comments section of the Activity-widget are shown when tabbing through the Dashboard. In trunk and 5.6 RC1 the link-row-actions are not shown. They are focused (I can see URL's in the browser bottom corner) but they are not visible.

An old similar ticket -> #32612

Attachments (5)

row-actions.png (15.6 KB) - added by kebbet 7 weeks ago.
51886.diff (536 bytes) - added by sabernhardt 7 weeks ago.
adds table-view-list class to dashboard widget
before_after.png (268.8 KB) - added by Hareesh Pillai 7 weeks ago.
Tested the patch and the focus style is visible.
51886-links.png (13.4 KB) - added by kebbet 7 weeks ago.
Thats in incorrect comparison. The issue is the action-links per comment that is hidden in RC1. (The colored links in this screenshot).
51886.png (7.1 KB) - added by pbiron 7 weeks ago.
with patch applied, tabbing through both shows and focus indicates the comment moderation action links

Download all attachments as: .zip

Change History (19)

@kebbet
7 weeks ago

#1 @sabernhardt
7 weeks ago

  • Milestone changed from Awaiting Review to 5.6

#2 @audrasjb
7 weeks ago

  • Focuses css added

I can reproduce the issue as well.

@sabernhardt
7 weeks ago

adds table-view-list class to dashboard widget

#3 @kebbet
7 weeks ago

Adding that class in the source code in the browser seems to solve the issue, and the widget works as in 5.5.3. (lo-fi testing :D)
Nice @sabernhardt!

#4 @sabernhardt
7 weeks ago

  • Keywords has-patch added; needs-patch removed

It seems this was caused by [49142]. The dashboard widget does not have the table-view-list class.

Adding the class in the widget is probably an easier way to fix this than editing the script again.

Last edited 7 weeks ago by sabernhardt (previous) (diff)

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


7 weeks ago

@Hareesh Pillai
7 weeks ago

Tested the patch and the focus style is visible.

@kebbet
7 weeks ago

Thats in incorrect comparison. The issue is the action-links per comment that is hidden in RC1. (The colored links in this screenshot).

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


7 weeks ago

#7 @SergeyBiryukov
7 weeks ago

  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing

#8 @pbiron
7 weeks ago

The patch seems to correct the problem (and I don't notice any unintended side-effects).

@pbiron
7 weeks ago

with patch applied, tabbing through both shows and focus indicates the comment moderation action links

#9 @pbiron
7 weeks ago

  • Keywords has-screenshots commit added

#10 @SergeyBiryukov
7 weeks ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 49725:

Administration: Make sure row actions for recent comments in Activity dashboard widget stay visible when a single row gets focus.

Follow-up to [49142].

Props sabernhardt, kebbet, hareesh-pillai, pbiron.
Fixes #51886. See #51516, #49715.

#11 @SergeyBiryukov
7 weeks ago

  • Keywords dev-feedback added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for backporting to the 5.6 branch after a second committer's review.

This ticket was mentioned in Slack in #core-committers by sergey. View the logs.


7 weeks ago

#13 @ryelle
7 weeks ago

  • Keywords dev-reviewed added; dev-feedback removed

[49725] looks good for backporting.

#14 @SergeyBiryukov
7 weeks ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 49727:

Administration: Make sure row actions for recent comments in Activity dashboard widget stay visible when a single row gets focus.

Follow-up to [49142].

Props sabernhardt, kebbet, hareesh-pillai, pbiron.
Reviewed by ryelle, SergeyBiryukov.
Merges [49725] to the 5.6 branch.
Fixes #51886. See #51516, #49715.

Note: See TracTickets for help on using tickets.