WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#51889 closed defect (bug) (fixed)

Search comment, makes all text bold (5.6 RC1)

Reported by: kebbet Owned by: SergeyBiryukov
Milestone: 5.6 Priority: normal
Severity: normal Version: 5.6
Component: Comments Keywords: has-screenshots has-patch commit
Focuses: ui Cc:

Description

When searching for a comment in 5.6 RC1 all text on the comment screen is set in bold. This is a regression from 5.5.3.

Attachments (3)

search-comments-bold.png (17.7 KB) - added by kebbet 8 months ago.
26d0b1fb3fb7a22c9ae0a351b1d0956e.gif (673.0 KB) - added by audrasjb 8 months ago.
Before applying Clorith’s patch
291890d11eba45fc88e750f94f8523e7.gif (1.2 MB) - added by audrasjb 8 months ago.
After applying Clorith’s patch

Download all attachments as: .zip

Change History (12)

#1 @johnbillion
8 months ago

  • Milestone changed from Awaiting Review to 5.6

Confirmed

#2 @Clorith
8 months ago

Good catch, introduced in r49284

A misplaced end of the bolding for the search result being included in the trimming function, instead out outside it.

This ticket was mentioned in PR #775 on WordPress/wordpress-develop by Clorith.


8 months ago

  • Keywords has-patch added; needs-patch removed

@audrasjb
8 months ago

Before applying Clorith’s patch

@audrasjb
8 months ago

After applying Clorith’s patch

#4 @audrasjb
8 months ago

  • Keywords commit added

Good catch. I was able to:

  1. Reproduce the issue;
  2. Fix it by applying PR from @Clorith 🎖

Marking this for commit.

#5 @azaozz
8 months ago

Looks like a typo. +1 to commit to the 5.6 branch as well.

#6 @SergeyBiryukov
8 months ago

  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing

#7 @SergeyBiryukov
8 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 49705:

Comments: Correct ending tag placement in the "Search results for: ..." subtitle.

Follow-up to [49284], [49286].

Props Clorith, kebbet, johnbillion, audrasjb, azaozz.
Fixes #51889. See #37353.

#8 @SergeyBiryukov
8 months ago

In 49706:

Comments: Correct ending tag placement in the "Search results for: ..." subtitle.

Follow-up to [49284], [49286].

Props Clorith, kebbet, johnbillion, audrasjb, azaozz.
Reviewed by azaozz, SergeyBiryukov.
Merges [49705] to the 5.6 branch.
Fixes #51889. See #37353.

Note: See TracTickets for help on using tickets.