WordPress.org

Make WordPress Core

#51903 closed enhancement (duplicate)

Check if plugin is making changes in permalinks and call flush_rules with it activation/deactivation

Reported by: oglekler Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Rewrite Rules Keywords:
Focuses: Cc:

Description

Often happened problem, where is necessary to call flush_rules, for example, if Yoast was installed 'sitemap_index.xml', will return 404 error, if Yoast will be uninstalled wp-sitemap.xml will return 404 error because in 'rewrite_rules' will be still present previous rules and user/site manager can have no idea that he/she needs to go and flush these rules manually.

Change History (2)

#1 @swissspidy
11 months ago

Right now it's a plugin's responsibility to flush permalinks on plugin activation/deactivation. I think it's impossible to detect whether a plugin is making any such changes without doing it.

#2 @ocean90
11 months ago

  • Component changed from Plugins to Rewrite Rules
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #47686.

Note: See TracTickets for help on using tickets.