WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 3 months ago

#51920 closed defect (bug) (fixed)

Metaboxes are partially hidden by .interface-interface-skeleton__footer element

Reported by: elliotcondon Owned by:
Milestone: 5.6.1 Priority: normal
Severity: normal Version: 5.6
Component: Editor Keywords: has-patch
Focuses: css Cc:

Description

When editing a post that contains metaboxes, the element div.interface-interface-skeleton__footer is absolutely positioned over the top of the metabox area.

Please see attached screenshots of the issue.

Attachments (2)

Screen Shot 2020-12-01 at 1.30.59 pm.png (375.1 KB) - added by elliotcondon 5 months ago.
Screenshot of block editor showing div.interface-interface-skeletonfooter element positioned over metaboxes.
Screenshot_2020-12-04 Edit Post ‹ WordPress 5 6 — WordPress.png (101.2 KB) - added by elliotcondon 5 months ago.
Screenshot showing issue effects entire Editor sidebar as well.

Download all attachments as: .zip

Change History (13)

@elliotcondon
5 months ago

Screenshot of block editor showing div.interface-interface-skeletonfooter element positioned over metaboxes.

#1 @markparnell
5 months ago

  • Component changed from General to Editor
  • Focuses css added
  • Version set to 5.6

Looks like this is a regression in 5.6 - I can reproduce the issue in 5.6RC2, but not in 5.5.3.

#2 @sabernhardt
5 months ago

  • Milestone changed from Awaiting Review to 5.6

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


5 months ago

#5 @hellofromTonya
5 months ago

  • Milestone changed from 5.6 to 5.6.1

Punting this ticket to 5.6.1 as it's too late for 5.6 RC3.

@elliotcondon
5 months ago

Screenshot showing issue effects entire Editor sidebar as well.

#6 @talldanwp
5 months ago

This was fixed by this merged pull request in the gutenberg repo https://github.com/WordPress/gutenberg/pull/26432, which unfortunately didn't make it into 5.6.

It should be possible to backport it for a 5.6.1 whenever that may be. I've labelled the github PR for backporting.

This ticket was mentioned in Slack in #core by markparnell. View the logs.


5 months ago

This ticket was mentioned in Slack in #core-editor by talldanwp. View the logs.


5 months ago

#9 @hellofromTonya
5 months ago

  • Keywords has-patch added

Marking as has-patch to move its workflow. As @talldanwp notes, it's been fixed upstream and could be backported for 5.6.1.

Leaving this ticket open for tracking purposes.

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


3 months ago

#11 @whyisjake
3 months ago

  • Resolution set to fixed
  • Status changed from new to closed

This has been backported and will be part of the 5.6.1 release.

Note: See TracTickets for help on using tickets.