WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 4 months ago

#51959 closed defect (bug) (invalid)

"the response is not a valid JSON response” error in WordPress

Reported by: elmwp1 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

When I go to update a page in WordPress Twenty Twenty, I get an error message stating "the response is not a valid JSON response" which prevents the update.

I have only received this error message in one WordPress site among many that I use. However, I have researched this error message in many sources and have yet to find any source that has an answer for the problem...

Change History (3)

#1 @azaozz
4 months ago

  • Keywords reporter-feedback added

Hi @elmwp1, welcome to trac.

When I go to update a page in WordPress Twenty Twenty

Could you give some more details please:

  • What are you using to update that page? The block editor, classic editor, etc.
  • This sounds like an error with an AJAX response. Could you look at the browser tools -> network and see what the actual response from the server is? This type of errors are often caused by a PHP warning that's returned together with the JSON response.

#2 @elmwp1
4 months ago

The error that I had been getting has ceased occurring...the cessation appears to have happened after the WordPress 5.6 update...

Thanks for your help...

#3 @azaozz
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Great!

Closing this as invalid. If it happens again, please reopen and paste the exact server response from the network tab in editor tools.

Note: See TracTickets for help on using tickets.