WordPress.org

Make WordPress Core

#51979 closed defect (bug) (reported-upstream)

WordPress 5.6.1-alpha-49778 update

Reported by: freedomlock2011 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.6
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

Since the WordPress updated that just applied to my online store was applied I have received a good 100 emails letting me know it upgraded. I get an email every 1-2 minutes.

Attachments (2)

Screenshot_20201209-011817_Gmail.jpg (464.0 KB) - added by freedomlock2011 11 months ago.
Multiple emails of the same update
Screenshot_20201209-012501_Gmail.jpg (709.0 KB) - added by freedomlock2011 11 months ago.
Another email

Download all attachments as: .zip

Change History (6)

@freedomlock2011
11 months ago

Multiple emails of the same update

#1 @iandunn
11 months ago

  • Component changed from Editor to Upgrade/Install
  • Keywords reporter-feedback added

Hi @freedomlock2011, thanks for letting us know, I'm sorry that happened, that's really annoying :(

Are you still getting the emails?

Do you know what version of WP you had before the upgrade? If it was a stable version like 5.5.3, then I'm guessing this problem is related to the `5.6 vs 5.6.1-alpha` bug, which is fixed now.

This ticket was mentioned in Slack in #core by dd32. View the logs.


11 months ago

#3 @dd32
11 months ago

Hey @freedomlock2011,

The emails should have now stopped, as your site has updated correctly to 5.6 now instead of staying on 5.6.1-alpha. The update to 5.6.1-alpha was unexpected and affected a minority of WordPress sites.

However, the emails you have received signify something else wrong, it appears that something is causing the WordPress upgrade routines to get triggered every minute, which should never happen under normal circumstances.

You're not alone, as amongst those who upgraded to 5.6.1-alpha quite a few other people have also experienced the same (or more) level of emails, it appears that it may be behaviour limited to a few specific web hosts, so I've reached out to a few contacts to see if we can find the cause (including one at your webhost).

If you're able to, are you able to share the contents of the cron option in your WordPress database? or let us know if there's anything being flagged in your Site Health tool in the WordPress dashboard?

#4 @dd32
11 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

In discussing with hosts, We've narrowed down the cause of the constant updates & emails.

It looks like some hosts systems were triggering wp_version_check() far more often than ideal, through their own systems (not WordPress cron) which was triggering development WordPress installs to constantly update themselves. So while WordPress would only trigger it every 12 hours, it was being triggered as often as every minute for some, through no fault of WordPress.

So, it doesn't appear there's any cron-related bugs here, just the API issue that caused this ticket to happen in the first place.

I'm going to close this ticket, as the issue is now fixed, @freedomlock2011 if you're still getting emails or updates are not working as expected, please reach out to me!
Sorry for the flood of emails you got, but thanks for reporting it since it's allowed me to stop it for others!

Note: See TracTickets for help on using tickets.