WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

#51994 closed defect (bug) (invalid)

Theme Twenty Twenty One- Menus are missing from the customizer when in live preview mode

Reported by: beckej Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.6
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

The new Twenty Twenty One theme works differently when it has been enabled from when it is in live preview mode from the customizer.

When in Live Preview mode, the color and dark mode menu is missing.

However, if you activate twenty twenty-one, and return to the customizer menu, the color and dark mode menu will appear.

https://ed-beck.com/wp-content/uploads/2020/12/Screen-Shot-2020-12-09-at-11.04.03-AM.png

Change History (4)

#1 @poena
6 months ago

  • Component changed from General to Bundled Theme

#2 @poena
6 months ago

Hi @beckej!
Thank you for reporting this.

I would like to ask for some more information to be able to test it.

Which plugins do you have installed, and is the preview correct if you deactivate them?
I am asking because I am wondering if there is a plugin installed, that is changing or removing the color section.

I have tested the following steps but I have not been able to reproduce it.

Test 1:
The theme is not installed.
In the Customizer, select "Change" in the Active theme section.
Select WordPress.org themes.
Locate Twenty Twenty-One in the theme list, click the button "Install and preview".
-All sections are displaying correctly.

Test 2:
The theme is installed but not active.
In the Customizer, select "Change" in the Active theme section.
Locate Twenty Twenty-One in the list of installed themes, click the button "Live Preview".
-All sections are displaying correctly.

(On Windows 10, using Google Version 87.0.4280.88 )

#3 @beckej
6 months ago

Hi @poena

I spent a little time disabling all plugins and then adding them back in one at a time. With no plugins activated, everything works as expected.

The plugin that was causing the issue was "Ocean Extra" an addon plugin for the theme OceanWP.

#4 @hellofromTonya
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hello @beckej,

Welcome to WordPress Trac!

I'm glad you found the plugin that is causing the issue:

The plugin that was causing the issue was "Ocean Extra" an addon plugin for the theme OceanWP.

As a plugin is the root cause (ie not theme or WordPress core), I'm closing this ticket. However, you can report the issue in the plugin's Support forum by going here https://wordpress.org/support/plugin/ocean-extra/.

Note: See TracTickets for help on using tickets.