WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 4 months ago

#51995 closed defect (bug) (fixed)

WordPress 5.6: Classic editor menu is not sticky

Reported by: majhajob Owned by: SergeyBiryukov
Milestone: 5.6.1 Priority: normal
Severity: normal Version: 5.6
Component: Editor Keywords:
Focuses: Cc:

Description

Hello,

i just updated the wordpress 5.6 and found the menu bar is not sticky :( which is really annoying while creating post i need to keep scroll up and down attaching the menu screen shot for the reference please release the update asap to fix this :(

thank you.

https://dilsedeals.in/wp-content/uploads/2020/12/line-1.jpg

Attachments (3)

line.jpg (16.1 KB) - added by majhajob 5 months ago.
classic-editor-toolbar-position-5.5-versus-5.6.jpg (157.3 KB) - added by sabernhardt 5 months ago.
toolbar positioning in 5.5.3 is not used in 5.6
classic-editor-toolbar-hidden-5.6.png (16.0 KB) - added by sabernhardt 5 months ago.
toolbar is not fixed, as the other buttons are

Download all attachments as: .zip

Change History (13)

@majhajob
5 months ago

#1 @sabernhardt
5 months ago

  • Component changed from General to Editor
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 5.6.1
  • Summary changed from Reporting Bug with 5.6 Version to WordPress 5.6: Classic editor menu is not sticky

#2 @sabernhardt
5 months ago

@majhajob Hi and thanks for the ticket!

I think the problem might not be the menu bar itself. When adding more content, the box keeps going beyond the screen. In 5.5, the positioning (and possibly height) was edited to keep the content area on the screen.

#3 @majhajob
5 months ago

yes but the issue is we need to keep scroll again & again for the menu option if the content is more and that's annoying with 5.6 version :(

@sabernhardt
5 months ago

toolbar positioning in 5.5.3 is not used in 5.6

@sabernhardt
5 months ago

toolbar is not fixed, as the other buttons are

#4 @sabernhardt
5 months ago

OK, I was wrong. The positioning had been on the toolbar itself, and without that, now it scrolls with the page. The Add Media button and the Visual/Text mode switcher buttons continue to stay fixed.

#5 @majhajob
5 months ago

yeah, so will it fix in future ?

#6 @johnbillion
5 months ago

  • Version set to 5.6

#7 @azaozz
4 months ago

  • Keywords needs-patch removed

Hi @majhajob, thanks for the bug report. Seems this is another "side effect" of the same bug as in #52046. Please test the patch there if you can: https://core.trac.wordpress.org/attachment/ticket/52046/52046.diff.

Related, possibly duplicate: #52046.

#8 @azaozz
4 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Changeset [49911].

Editor: Trigger the tinymce-editor-init custom jQuery event on DOM ready. Otherwise TinyMCE may initialize earlier and handlers attached on DOM ready may not get triggered. Fixes making the editor menu "sticky" and setting/resetting some screen options on the old Edit Post screen.

Fixes 52046, 51995.

#9 @azaozz
4 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopen for the 5.6 branch.

#10 @SergeyBiryukov
4 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from reopened to closed

In 49996:

Editor: Trigger the tinymce-editor-init custom jQuery event on DOM ready.

Otherwise TinyMCE may initialize earlier and handlers attached on DOM ready may not get triggered. Fixes making the editor menu "sticky" and setting/resetting some screen options on the old Edit Post screen.

Props azaozz, majhajob, sabernhardt.
Merges [49911] to the 5.6 branch.
Fixes #52046, #51995.

Note: See TracTickets for help on using tickets.