WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#5200 closed defect (bug) (duplicate)

Options object cache can become out of sync with the database.

Reported by: markjaquith Owned by:
Milestone: Priority: high
Severity: major Version: 2.2.3
Component: General Keywords:
Focuses: Cc:

Description

I have a client with a high volume site (both in terms of view and in terms of entries posted that has been having problems with future-published entries sometimes not publishing at their correct times. I've been monitoring things, and it seems that when problems occur, the object cache has become out of sync with the database. We're using the APC backend in this case, though I don't think that's the cause of the issues.

Specifically, sometimes the database "cron" entry will have cron items that aren't found when you get_option('cron');

There may be a race condition with concurrent updates.

We can likely improve this in the option API, but we might not be able to eliminate it entirely. It may be prudent to revisit our method of storing cron entries, as an option is not a good place to store a frequently-updated serialized array.

The idea of a multi-use "meta" table has been floated, and this might be another good use of that, as cron entries could have their own meta type.

Change History (1)

comment:1 @markjaquith8 years ago

  • Milestone 2.4 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Oops, double-clicked by accident. #5199

Note: See TracTickets for help on using tickets.