WordPress.org

Make WordPress Core

Opened 10 months ago

Closed 9 months ago

Last modified 7 months ago

#52053 closed defect (bug) (reported-upstream)

Keyboard Shortcut Not working in code editor make fullscreen mode

Reported by: urvik1 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.6
Component: Editor Keywords: needs-testing needs-design needs-patch has-screenshots
Focuses: Cc:

Description

Hello Guys

Full-screen mode into Code Editor keyboard shortcut key is not working.
https://www.screenpresso.com/=MS16c

Thanks,

Attachments (1)

52053-1 (3.5 MB) - added by Laxman Prajapati 10 months ago.
The Keyboard Shortcut key is working fine for me in the code editor to make the full-screen mode.

Change History (17)

#1 @urvik1
10 months ago

  • Summary changed from https://www.screenpresso.com/=MS16c to Keyboard Shortcut Not working in code editor make fullscreen mode

#2 @Laxman Prajapati
10 months ago

  • Keywords has-screenshots added

Hi @urvik1,

Thanks for the ticket.

The Keyboard Shortcut key is working fine for me in the code editor to make the fullscreen mode.

Can you please check with a different browser?
Like: Firefox, Chrome ext..?

Please find attached for your reference(52053-1.gif).

Thanks,
Laxman P

Last edited 10 months ago by Laxman Prajapati (previous) (diff)

@Laxman Prajapati
10 months ago

The Keyboard Shortcut key is working fine for me in the code editor to make the full-screen mode.

#3 follow-up: @urvik1
10 months ago

but i'm allready checking into the chrome it not working
https://drive.google.com/file/d/1ch-dCHV6VICgGqZhHHJqxXPzF1-V7bmp/view?usp=drivesdk

Thanks,

#4 in reply to: ↑ 3 @Laxman Prajapati
10 months ago

Requested access for the same.
Please allow me.

Meanwhile can you please check with another system as well?

I have checked with two different systems with different browser and seems working fine for me so.

Your browser version please?

Thanks,
Laxman P

Replying to urvik1:

but i'm allready checking into the chrome it not working
https://drive.google.com/file/d/1ch-dCHV6VICgGqZhHHJqxXPzF1-V7bmp/view?usp=drivesdk

Thanks,

This ticket was mentioned in Slack in #design by paaljoachim. View the logs.


10 months ago

#7 @paaljoachim
10 months ago

  • Keywords needs-design-feedback removed

Hi

I just checked on Mac running WordPress 5.6 and with and without Gutenberg plugin version 9.5.2 activated. Testing with Safari, Firefox and Chrome. Here on my Mac the shortcut works.

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


9 months ago

#9 @ryokuhi
9 months ago

  • Focuses accessibility removed

Hello @urvik1 and thanks for reporting the issue.
It was discussed today during the weekly accessibility team's bug scrub.
We are removing the accessibility focus, as this doesn't seem to be an accessibility issue.
Feel free to add the label again if you think that our team can help in solving the issue!

#10 @poena
9 months ago

  • Focuses accessibility added

Hi!

I am not able to reproduce this on Windows 10 with Chrome version 87.0.4280.88, with and without Gutenberg version 9.5.2.

Are you using the shortcut on the on-screen keyboard as seen in the video? It is working for me with the default Windows on-screen keyboard and a physical keyboard.

Last edited 9 months ago by poena (previous) (diff)

#11 @poena
9 months ago

  • Focuses accessibility removed

#12 @sabernhardt
9 months ago

I double-checked in Windows Firefox 84 and Chrome 87. I can use the Visual/Code view shortcut Ctrl+Shift+Alt+M, yet I can't use the full-page editor shortcut Ctrl+Shift+Alt+F.

I tried with physical keys and then with the standard Windows on-screen keyboard. I don't think I have any user settings that would affect this. The keyboard layout is U.S., but if that's relevant to the issue I probably should not be able to use the other shortcut.

This ticket was mentioned in Slack in #core by lukecarbis. View the logs.


9 months ago

#14 @sabernhardt
9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Now this is moved to the Gutenberg repo for attention there:
https://github.com/WordPress/gutenberg/issues/27923

#15 @sabernhardt
8 months ago

I wrote this on the GitHub issue, but I'll repeat it here:

Ctrl + Shift + Alt + F apparently was reserved as a Windows shortcut since version 1903, and I was using 1909.
reserved Windows shortcut

After updating to 20H2, using the shortcut worked for me, so it seems that Windows un-reserved it. If you have trouble with the shortcut in Windows 10-20H2 or later (or with another operating system), please comment on GB27923.

#16 @sterndata
7 months ago

CTRL-ALT-SHIFT-M inserts an image but leaves one at a blank screen with an X at the top right to close the media library.

Note: See TracTickets for help on using tickets.