WordPress.org

Make WordPress Core

Opened 13 years ago

Closed 13 years ago

#5207 closed defect (bug) (invalid)

mu-plugins directory doesn't recognize plugins in a sub-folder

Reported by: jsherk Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: wpmu, mu-plugins
Focuses: Cc:

Description

In WPMU 1.2.5a...

I dropped the whole eventcalendar3 folder into the plugins directory, and with Site Admin->Options->Plugins Enabled, I am able to Activate and Deactivate the plugin individually as required on each blog.

Now I understand that if you put a plugin in the mu-plugins directory, it will auto-activate and you will not see the PLUGINS menu appear on the admin screen. BUT... if you drop the whole eventcalendar3 folder into the mu-plugins directory, it does not recognize the plugin at all and does not auto-activate. You need to take everything out of the eventcalendar3 folder, and put it directly into the mu-plugins directory, and then it will work.

The only problem with this, is that if you need to remove a plugin, you now have your mu-plugins directory full of a bunch of files, and you don't know which ones go with each plugin.

Since the plugins folder can recognize a plugin in it's sub-folder, I would think that the expected behaviour of the mu-plugins directory should be the same.

Change History (1)

#1 @johnbillion
13 years ago

  • Milestone 2.5 deleted
  • Resolution set to invalid
  • Status changed from new to closed

I reported this on WPMU Trac in May (http://trac.mu.wordpress.org/ticket/343) and it got closed as wontfix. Feel free to reopen it over there as I think it really makes sense.

Closing as invalid here, continue over at WPMU Trac.

Note: See TracTickets for help on using tickets.