WordPress.org

Make WordPress Core

#52075 closed defect (bug) (fixed)

Word Count on Classic Editor doesn't update in real time on Firefox unless saved

Reported by: rebasaurus Owned by:
Milestone: 5.6.1 Priority: normal
Severity: normal Version: 5.6
Component: TinyMCE Keywords: close
Focuses: Cc:

Description

This has been happening on 5.6 using Firefox 83.0. I was unable to reproduce on 5.5.1.

To reproduce on 5.6:

1) Install the Classic Editor plugin and enable it
2) Type out a bunch of words on a new post and see that "Word count: 0" remains
3) Save as draft and see that "Word count: x" has updated

Attachments (1)

52075-testing-works.gif (806.4 KB) - added by hellofromTonya 11 months ago.
Re-testing in Firefox version 84.0.2. Works!

Download all attachments as: .zip

Change History (11)

#1 @rebasaurus
12 months ago

Also, I just wanted to mention that it's not reproducible using Chrome — just FF. Using the jquery migrate helper plugin does resolve the issue.

Last edited 12 months ago by rebasaurus (previous) (diff)

#2 @hellofromTonya
11 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 5.6.1

Hello @rebasaurus,

Welcome to WordPress Core Trac! Thank you for the ticket.

With WP 5.6:

  • I was able to reproduce the problem in Firefox v84.0.1.
  • It worked as expected in Chrome Version 87.0.4280.88 and Safari Version 14.0.2.

With 5.5.3:

  • It worked as expected in Firefox, Chrome, and Safari.

My local testing environment:

  • Theme: Twenty Twenty-One
  • Plugins: only the Classic Editor plugin
  • PHP: 7.3.5
  • Classic Editor: 1.6

Moving this ticket into 5.6.1.

#3 @rebasaurus
11 months ago

Looks like https://core.trac.wordpress.org/ticket/52046 is related and there was a changeset pushed to it recently.

#4 @justinahinon
11 months ago

Yes @rebasaurus. I can confirm that. I'm not able to reproduce the issue on the latest version of trunk.

This ticket was mentioned in Slack in #core by metalandcoffee. View the logs.


11 months ago

@hellofromTonya
11 months ago

Re-testing in Firefox version 84.0.2. Works!

#6 @hellofromTonya
11 months ago

  • Keywords needs-patch removed

Checked out the current 5.6.1 branch. I too can confirm that it now works (see attached gif).

Last edited 11 months ago by hellofromTonya (previous) (diff)

#7 @hellofromTonya
11 months ago

  • Keywords reporter-feedback added

@rebasaurus is the issue resolved for you too?

#8 @hellofromTonya
11 months ago

  • Keywords close added

Marking this ticket as a close candidate pending reporter feedback as we're unable to reproduce the reported problem with the latest 5.6.1 branch.

#9 @rebasaurus
11 months ago

  • Keywords reporter-feedback removed

Thanks @hellofromTonya. I've just tested the latest nightly build and it appears to no longer be an issue. I think we can close this now.

#10 @hellofromTonya
11 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Closing as "fixed" as it was fixed in core since being first reported.

Note: See TracTickets for help on using tickets.