WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 3 months ago

#52077 closed defect (bug) (reported-upstream)

Kindle embed loses captions on edit

Reported by: tracilovelot Owned by:
Milestone: Priority: normal
Severity: minor Version: 5.6
Component: Embeds Keywords: has-screenshots
Focuses: Cc:

Description

If I edit a post created prior to the WordPress 5.6 update, Kindle Embeds all show an error: This block contains unexpected or invalid content. If I hit the Attempt Block Recovery button, it recovers the block and keeps the caption, thankfully. So it's annoying to have to do on every single Kindle Embed block on old content, but it's not the end of the world.

However...

If I edit an existing post that was either created or updated after 5.6, the Kindle embeds all automatically refresh upon edit post pageload. (&action=edit) Not something I want to happen. It's as though their URLs have just been added, but the page just loaded, so it's not caused by something I did. Unfortunately, all the blocks refresh so fast I can't grab a screenshot except after the damage is done. After that automatic refresh, the Kindle embeds lose their captions. This has only begun happening since the most recent wordpress update 5.6 using the default Guten Kindle embed block.

See attached screenshots from same post. First editing it for the first time since 5.6 released (Recovery works). Then editing it again, which causes the Kindle Embed blocks to refresh and lose their captions.

Attachments (2)

edit post created before 5.6.png (39.4 KB) - added by tracilovelot 4 months ago.
edit of post created before 5.6 - recovery of Kindle embeds
edit post updated after 5.6 - refresh lost the caption.png (239.3 KB) - added by tracilovelot 4 months ago.
ediit of post updated after 5.6 - Kindle embed refresh lost caption that was previously recovered

Download all attachments as: .zip

Change History (4)

@tracilovelot
4 months ago

edit of post created before 5.6 - recovery of Kindle embeds

@tracilovelot
4 months ago

ediit of post updated after 5.6 - Kindle embed refresh lost caption that was previously recovered

This ticket was mentioned in Slack in #core by lukecarbis. View the logs.


3 months ago

#2 @isabel_brison
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Thanks @tracilovelot! I can reproduce this issue with WP 5.6 and have reported it upstream in the Gutenberg repo: https://github.com/WordPress/gutenberg/issues/27980

This ticket can be closed now.

Note: See TracTickets for help on using tickets.