Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#52085 closed enhancement (duplicate)

Provide an action hook to help developers to extend the Privacy Settings screen

Reported by: audrasjb's profile audrasjb Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Privacy Keywords: close
Focuses: ui, privacy Cc:

Description

In GDPR Data Request Form plugin support forum, many users asked me to add a setting to change the email of the administrator who receive the Privacy requests email notifications.

Given there is no hook on the Privacy settings page, I added my form using some JavaScripts hacks (see screenshot below). It works, but it's not super clean and developer-friendly.

I think it would be nice to add an action filter at the bottom of the screen, so developers can extend the features of this settings screen as they want. I can imagine various use cases for this action hook.

Attachments (2)

Capture d’écran 2020-12-15 à 23.25.20.png (418.5 KB) - added by audrasjb 3 years ago.
Use case: provide an email settings for requests notifications
52085.diff (469 bytes) - added by audrasjb 3 years ago.
Implementation proposal: add an after_privacy_settings_sections action hook

Download all attachments as: .zip

Change History (4)

@audrasjb
3 years ago

Use case: provide an email settings for requests notifications

@audrasjb
3 years ago

Implementation proposal: add an after_privacy_settings_sections action hook

#1 @garrett-eclipse
3 years ago

  • Keywords close added

Hey @audrasjb I believe reworking the Privacy Settings to use the actual Settings API is our best course of action for this, it's been requested before. See #49602 for a hook request. We have #44145 for the Settings API rework which I believe should enable you to accomplish the same thing as your desired hook. Neither have seen much action of late, but there was a redesign project that started that would implement the settings api for us, see #49264.

Would the Settings API resolve your requirement? Am thinking this can be closed as a duplicate.

#2 @audrasjb
3 years ago

  • Keywords needs-patch 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #49602.

Indeed! The hook patch was so simple that I thought nobody asked for this before, and I didn't even thought to search on Trac for any existing ticket 😅 My bad, sorry!

Note: See TracTickets for help on using tickets.