WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 3 months ago

Last modified 7 days ago

#52107 closed defect (bug) (invalid)

Error when associating a category to a post : "Sorry, you are not allowed to assign the provided terms."

Reported by: webtechIMT Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.6
Component: Taxonomy Keywords:
Focuses: administration, multisite Cc:

Description (last modified by SergeyBiryukov)

Hi,

We use WordPress Multisite 5.6 (387 sites)

Steps to reproduce in a site :

Create a new category "My category" THEN
Create a new tag "My tag" THEN
Create a new category with the same name of an existing tag, let's say "My tag" THEN
Create a new tag with the same name of an existing category, let's say "My category"

Now it will break if you do the following:

Edit the category "My tag" with the name of an existing tag, you'll get "You need a higher level of permission. Sorry, you are not allowed to edit this item."
Edit the tag "My category" with the name of an existing category, you'll get "You need a higher level of permission. Sorry, you are not allowed to edit this item."
Create / edit a content and assign the category "My tag" (with the name of an existing tag) or assign the tag "My category" (with the name of an existing category) and you'll get a 403 error with the response

The same as described in #46297.

I used the plugin https://github.com/jjeaton/wp-find-shared-terms on our site where we have this error message and the result is :

Splitting all shared terms
Process complete!
Processed: 42
Split: 0
Skipped: 42
Errors: 0

But the problems remains...

Do you have a solution ?

Best regards,
Olivier.

Change History (9)

#1 @SergeyBiryukov
4 months ago

  • Component changed from General to Taxonomy
  • Description modified (diff)
  • Focuses multisite added

This ticket was mentioned in Slack in #core by lukecarbis. View the logs.


3 months ago

#3 @lukecarbis
3 months ago

Hi @webtechIMT – thanks for opening this ticket. This is very strange behaviour – potentially influenced by a theme or plugin? Could you please try with a default theme and all plugins disabled?

Additionally, are the steps to reproduce done in the WP Admin via the sidebar, or completely in the context of the Gutenberg editor sidebar?

#4 @webtechIMT
3 months ago

Hi @lukecarbis,

I can't try to reproduce the bug with disbaling plugins and with default theme on the production multisites WP (used by 367 sites)

I can try to reproduce it on a test site but it will be worth you do it on your side. The same happens in this ticket : #46297.

Tell me.

Regards,
Olivier.

#5 @lukecarbis
3 months ago

@webtechIMT I've just followed each of the steps you provided in a new multisite instance, but when I get to the "Edit the category "My tag" with the name of an existing tag" part, everything works as expected.

I've tried editing both the name and the slug to match an existing tag.

I'm unable to replicate the issue. Happy to try again if you'd like to provide more detailed instruction – I was not using the Gutenberg editor for any of this, just the Posts > Categories and Posts > Tags pages via the menu.

#6 @webtechIMT
3 months ago

OK, I'll try asap on my test site and let you know if I reproduce it.

#7 @webtechIMT
3 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Hi,

I can't reproduce on my test multisite website. So I close the ticket. It could be related to WPML plugin, I'll try with their support.

#8 @desrosj
4 weeks ago

  • Milestone Awaiting Review deleted

Thanks for following up @webtechIMT!

If you were able to figure out the root cause of your issue, sharing any details you have here could help other users in the future.

#9 @webtechIMT
7 days ago

I don't have a solution. I'm still waiting for a fix : https://core.trac.wordpress.org/ticket/46297#comment:16

Note: See TracTickets for help on using tickets.