WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

#52114 closed defect (bug) (invalid)

Critical Error after updating to WordPress from 5.5.3 to 5.6

Reported by: theuseful Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.6
Component: Application Passwords Keywords:
Focuses: Cc:

Description

Hi,

I’m not able to enter my wordpress admin dashboard of my site after upgrading from 5.5.3 to 5.6: WP admin proposes to upgrade database and then shows critical error message.

Logs are:
"PHP Fatal error: Uncaught Error: Class ‘WP_Application_Passwords’ not found in *user.php:316
..."

Could you help with it, please?

Change History (1)

#1 @desrosj
9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @theuseful,

The class mentioned in the log file is found in a new file added in 5.6. It seems your update did not complete successfully, most likely because the updater had trouble creating the new file.

The best way forward is to manually replace the files in WordPress with a fresh copy from wordpress.org. You can find more detailed instructions in the following plugin support article: https://wordpress.org/support/article/updating-wordpress/#manual-update.

I'm going to close this out because this is a support request, which is better suited for the WordPress.org Support Forums. I'm pretty confident that this will fix your issue. But if it doesn't, feel free to open a support request.

If you are able to verify that the file containing this class is indeed present and identify specific conditions where that file will not be properly included for use, feel free to reopen this with more details.

Note: See TracTickets for help on using tickets.