WordPress.org

Make WordPress Core

Opened 5 weeks ago

Closed 2 weeks ago

#52119 closed defect (bug) (duplicate)

Create menu without link

Reported by: w4wan Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.6
Component: Menus Keywords:
Focuses: accessibility Cc:

Description

Scenario to reproduce:

  • Create a new menu
  • Create a new 'custom link'
    • Do not set an URL
    • Type a title
  • Add to menu

The new entry is created but it will generate a <a> tag instead of a <p> which break web semantic because there is no link or no action on this entry.

Change History (5)

#1 @w4wan
5 weeks ago

Actually you cannot directly type an empty URL when you create a new menu entry. You need to set something (eg '#'), then update it to blank inside the menu panel.

#2 @SergeyBiryukov
5 weeks ago

  • Component changed from General to Menus
  • Focuses coding-standards removed

This ticket was mentioned in Slack in #core by lukecarbis. View the logs.


2 weeks ago

#5 @isabel_brison
2 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Marking this as duplicate of #13273, because adding non-link menu items will make it unnecessary to create custom links and remove their URLs as a workaround.

Note: See TracTickets for help on using tickets.