WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 8 weeks ago

Last modified 3 weeks ago

#52134 closed defect (bug) (duplicate)

Post created with patterns - missing excerpt

Reported by: MarkS99 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.6
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

When posts are setup using some of the stock patterns, no excerpt is available for the post on blog page.
Seems to affect the following 'stock' patterns:
Columns: Two Columns, Two Columns with images, Three columns with buttons.
Text: Heading & Text, and Quote
Headers: Large Header with heading, Large header with a heading and a button.

Tested on custom theme, and also clean vanilla WP5.6 install, using Twenty Twenty-One

Change History (6)

#1 @MarkS99
7 months ago

Just to note, I have also tested editing and replacing default text - excerpt is still not available.

This ticket was mentioned in Slack in #core by peterwilsoncc. View the logs.


8 weeks ago

#3 @chaion07
8 weeks ago

#47637 was marked as a duplicate.

#4 @chaion07
8 weeks ago

  • Component changed from General to Editor
  • Keywords reporter-feedback added
  • Severity changed from major to normal

Hello @MarkS99! Thank you for reporting this. We reviewed the ticket during one of our [recent triage sessions]https://wordpress.slack.com/archives/C02RQBWTW/p1622524033126700. Based on the feedback from the team we have modified the information on the ticket.

@mamaduka also shared [his feedback]https://wordpress.slack.com/archives/C02RQBWTW/p1622524926134400 referencing [excerpt_remove_blocks]https://developer.wordpress.org/reference/functions/excerpt_remove_blocks/. So columns should be removed. TT1 displayed excerpt on homepage by default and we could see them removed. There's also excerpt_allowed_blocks filter, so this behavior can be altered. So if we're using a custom theme with inner blocks, then the inner blocks will need to be added via a filter in that function. When we wrapped the column pattern in a group the excerpt was gone.

#5 @chaion07
8 weeks ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #47637.

Updated the ticket information upon further consultation.

#6 @desrosj
3 weeks ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.