WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 5 months ago

#52146 closed defect (bug) (invalid)

get_self_link does not support SSL

Reported by: dshanske Owned by:
Milestone: Priority: normal
Severity: minor Version: 5.3
Component: General Keywords: has-patch reporter-feedback
Focuses: Cc:

Description

The get_self_link function introduced in 5.3, which merely moved the code from self_link, will always return http links.

It should use, is_ssl() to determine if it returns http or https.

Attachments (1)

52146.diff (602 bytes) - added by mukesh27 7 months ago.
Patch.

Download all attachments as: .zip

Change History (5)

@mukesh27
7 months ago

Patch.

#1 @mukesh27
7 months ago

  • Keywords has-patch added; needs-patch removed

Hi there!

52146.diff patch fix the ssl issue.

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


6 months ago

#3 @ocean90
5 months ago

  • Keywords reporter-feedback added

@dshanske Could you provide some steps to reproduce the issue?

get_self_link() uses set_url_scheme() which already sets the correct scheme based on is_ssl() so 52146.diff isn't necessary here.

#4 @johnbillion
5 months ago

  • Milestone 5.7 deleted
  • Resolution set to invalid
  • Status changed from new to closed

I can't reproduce this issue either so I'll close it off for now. @dshanske if you have steps to reproduce please let us know!

Note: See TracTickets for help on using tickets.