WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 6 weeks ago

Last modified 6 weeks ago

#52251 closed defect (bug) (worksforme)

Password Protected pages not working with PHP 8

Reported by: johnzapf Owned by:
Milestone: Priority: normal
Severity: major Version: 5.6
Component: Posts, Post Types Keywords: php8 reporter-feedback
Focuses: Cc:

Description

Password Protected pages not working with PHP 8

Change History (3)

#1 @SergeyBiryukov
7 months ago

  • Component changed from General to Posts, Post Types
  • Focuses accessibility performance coding-standards removed
  • Keywords php8 reporter-feedback added

Hi there, welcome to WordPress Trac! Thanks for the report.

Could you provide the steps to reproduce the issue on a clean install? Does it still happen with all plugins disabled and a default theme (Twenty Twenty-One) activated?

Creating and viewing password-protected posts or pages seems to work as expected for me on PHP 8.0.

Last edited 6 weeks ago by SergeyBiryukov (previous) (diff)

#2 @johnzapf
7 months ago

it works with all plugins disabled. I use Beaver builder so that may be the issue?

Last edited 7 months ago by johnzapf (previous) (diff)

#3 @hellofromTonya
6 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hello @johnzapf,

I too am unable to reproduce the problem on an existing and clean installs. It does not seem to be due to WordPress core.

Could it be a conflict from a plugin? Yes, it could be. For Beaver Builder, you can seek help in the plugin's support forum https://wordpress.org/support/plugin/beaver-builder-lite-version/ or directly on their site.

You can also seek additional help through the Support forums https://wordpress.org/support/.

I'll close this ticket as it does not seem to be caused by WordPress core. However, if the problem is identified to be core itself, please reopen with steps to reproduce and any other information to help contributors continue investigating.

Note: See TracTickets for help on using tickets.