WordPress.org

Make WordPress Core

#52285 closed defect (bug) (duplicate)

Register - create password link bug

Reported by: jardah Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.6
Component: Users Keywords:
Focuses: Cc:

Description

Hi, if you are going to register with nick that include space (eg. Hello WP), you get unclickable link in some email clients.
So you click this:

domain.com/login/?action=rp&key=xxxxxxxxxx&login=Hello
-which get an invalid link error, cuz we have wrong user name

instead of this:

domain.com/login/?action=rp&key=xxxxxxxxxx&login=Hello WP

I recommend to auto replace spaces with %20 for better cross email support. Thanks!

Change History (1)

#1 @SergeyBiryukov
11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #34372.

I recommend to auto replace spaces with %20 for better cross email support.

As far as I can tell, this already happens via rawurlencode() in the retrieve_password() function.

I could not reproduce the issue on a clean install. Some more information would be helpful here, let's continue the discussion on the other ticket.

Note: See TracTickets for help on using tickets.