Make WordPress Core

Opened 3 years ago

Closed 15 months ago

#52302 closed defect (bug) (wontfix)

Emoji detection not working in the latest Chrome on Windows 7

Reported by: sergeybiryukov's profile SergeyBiryukov Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.5
Component: Emoji Keywords: has-screenshots close
Focuses: Cc:

Description

Reported by @Webliberty on Russian WP Slack.

  1. Create a post with this content: :) ;).
  2. View the post in the latest Chrome (version 87.0.4280.141 as of writing) on Windows 7.
  3. Instead of regular colored images, you'll see one blank square and one monochrome icon.

If the platform does not support the current emoji set natively, the Twemoji fallback is supposed to replace it with images, but does not kick in as expected.

Some history here:

Upon some testing, this used to work in WordPress 5.4 and no longer works in WordPress 5.5, so appears to be a regression in [48048].

Reverting the changes to js/_enqueues/lib/emoji-loader.js from [48048], as well as the corresponding minified fragment in _print_emoji_detection_script() to the one from WordPress 5.4 makes the images display again.

Since extended support for Windows 7 has ended a year ago on January 14, 2020, this may very well be an edge case. This ticket was created for reference just in case it might still be worth fixing.

Attachments (1)

52302.png (1.8 KB) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (4)

@SergeyBiryukov
3 years ago

#2 @desrosj
19 months ago

  • Keywords close added

Since Windows 7 has now been unsupported for almost 3 years, thinking this can probably be closed out.

@SergeyBiryukov are you able to reproduce this today in a way that makes you feel this should remain open for further investigation?

#3 @kraftbj
15 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I'm going to close this, but can be reopened if deemed important to investigate.

Note: See TracTickets for help on using tickets.