WordPress.org

Make WordPress Core

Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#52315 closed defect (bug) (invalid)

The Readme.html on the repository "https://github.com/WordPress/WordPress" needs to be fixed

Reported by: pawki07 Owned by: audrasjb
Milestone: Priority: normal
Severity: normal Version:
Component: Help/About Keywords: has-patch reporter-feedback close
Focuses: Cc:

Description

Many links on the readme.html have not been specified properly.

Change History (11)

This ticket was mentioned in PR #872 on WordPress/wordpress-develop by pawki07.


11 months ago

  • Keywords has-patch added

#3 @Hareesh Pillai
11 months ago

  • Keywords reporter-feedback added

Hi @pawki07, welcome to Trac!

I have gone through the PR, and the links in the readme file seem fine as is.
Could you help understand what benefits the proposed changes bring?

Thank you.

#4 @Hareesh Pillai
11 months ago

On further inspection, it looks like some URLs are being redirected to other links.
We should evaluate changing them in the readme file directly.

https://secure.php.net/ redirects to https://www.php.net/
https://wordpress.org/donate/ redirects to https://wordpressfoundation.org/donate/

#5 @audrasjb
11 months ago

  • Component changed from General to Help/About
  • Focuses accessibility performance removed
  • Keywords close added; needs-docs removed
  • Owner set to audrasjb
  • Status changed from assigned to reviewing

Hello @pawki07, welcome to Trac and thank you for opening this ticket!

The goal of the two pull requests above isn't clear to me, though. @pawki07 could you please clarify why do you need/want an extra space inside all those links? It doesn't appear to be necessary or recommended by any standard.

Last edited 11 months ago by audrasjb (previous) (diff)

#6 @prbot
11 months ago

pawki07 commented on PR #873:

Hello,
The readme file looks fine as it is without this PR. Why do you want to add those extra spaces? They aren't necessary :)

https://i0.wp.com/user-images.githubusercontent.com/57265762/104816003-42640580-583e-11eb-802d-2b158c55a379.jpg
I was talking about the links which is visible on the readme.html. Have a look at it.

#7 @prbot
11 months ago

audrasjb commented on PR #873:

Hello,
The readme file looks fine as it is without this PR. Why do you want to add those extra spaces? They aren't necessary :)

https://i0.wp.com/user-images.githubusercontent.com/57265762/104816003-42640580-583e-11eb-802d-2b158c55a379.jpg
I was talking about the links which is visible on the readme.html. Have a look at it.

Sorry But I don't understand what's the issue here @pawki07 ?

#8 @ocean90
11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from reviewing to closed

Hello @pawki07, the linked WordPress GitHub repo is a mirror of https://build.trac.wordpress.org/browser/trunk and only contains the files which are used in a release ZIP. Therefore it doesn’t need to to be optimized for GitHub which is also usually done by a markdown file instead of a HTML file.

Note that this is different from the wordpress-develop mirror which has a proper readme file and is actually used for contributions.

#9 @SergeyBiryukov
11 months ago

Looking at the screenshot above, it seems like the issue is that GitHub's UI displays readme.html file as plain text (which is to be expected, since it's not in Markdown format, unlike README.md), but at the same time it highlights URLs incorrectly, not recognizing the trailing double quote. Looking at the page source, the markup is clearly broken:

&lt;a href="<a href="https://wordpress.org/&quot;&gt;&lt;img" rel="nofollow">https://wordpress.org/"&gt;&lt;img</a> alt="WordPress" src="wp-admin/images/wordpress-logo.png" /&gt;&lt;/a&gt;

That would be something for GitHub to fix, I don't think we should add spaces here just to work around their preview issues.

Last edited 11 months ago by SergeyBiryukov (previous) (diff)

#10 @prbot
11 months ago

pawki07 commented on PR #873:

Hello,
The readme file looks fine as it is without this PR. Why do you want to add those extra spaces? They aren't necessary :)

https://i0.wp.com/user-images.githubusercontent.com/57265762/104816003-42640580-583e-11eb-802d-2b158c55a379.jpg
I was talking about the links which is visible on the readme.html. Have a look at it.

Sorry But I don't understand what's the issue here @pawki07 ?

As explained by @SergeyBiryukov , now I understood that markup is broken and we need not add whitespaces to fix it. Thank you for the clarification.

#11 @SergeyBiryukov
11 months ago

#52318 was marked as a duplicate.

Note: See TracTickets for help on using tickets.