WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#52318 closed defect (bug) (duplicate)

Markup broken

Reported by: pawki07 Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: General Keywords:
Focuses: Cc:

Description

GitHub's UI displays readme.html ( wordpress-develop/src/readme.html )file as plain text , but at the same time it highlights URLs incorrectly, not recognizing the trailing double quote. Looking at the page source, the markup is clearly broken:

&lt;a href="<a href="https://wordpress.org/&quot;&gt;&lt;img" rel="nofollow">https://wordpress.org/"&gt;&lt;img</a> alt="WordPress" src="wp-admin/images/wordpress-logo.png" /&gt;&lt;/a&gt;

Attachments (1)

Screenshot (723)_LI.jpg (1.3 MB) - added by pawki07 12 months ago.

Download all attachments as: .zip

Change History (4)

#1 follow-up: @audrasjb
12 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Hi @pawki07 and thank you for opening this ticket,

As said in the previous ticket (#52315), this has to be fixed upstream by GitHub. We won't change the way we code HTML links because GitHub doesn't display them the good way in their preview screens :)

Closing this ticket as wontfix. You can also get more details in the previous ticket - #52315.

Thank you

Last edited 12 months ago by audrasjb (previous) (diff)

#2 in reply to: ↑ 1 @pawki07
12 months ago

Replying to audrasjb:

Hi @pawki07 and thank you for opening this ticket,

As said in the previous ticket (#52315), this has to be fixed upstream by GitHub. We won't change the way we code HTML links because GitHub doesn't display them the good way in their preview screens :)

Closing this ticket as wontfix. You can also get more details in the previous ticket - #52315.

Thank you

#3 @SergeyBiryukov
12 months ago

  • Resolution changed from wontfix to duplicate

Duplicate of #52315.

Note: See TracTickets for help on using tickets.