Make WordPress Core

Opened 3 years ago

Closed 6 weeks ago

#52361 closed defect (bug) (wontfix)

Twenty Twenty-One: "Continue Reading" link will only show if there is minimum amount of text before the "Read More" block

Reported by: mrfoxtalbot's profile mrfoxtalbot Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.6
Component: Bundled Theme Keywords: close 2nd-opinion
Focuses: Cc:

Description

## Description

Unless there is a certain minimum amount of text before the "Read More" block, the "Continue Reading" links will just now show on the public site's homepage (set to posts), or archives (I tried category, author and date)

## Step-by-step reproduction instructions

  1. Create new page or post
  2. Add a paragraph block with just few words (two lines or less)
  3. Add a "Read More" block beneath this short paragraph
  4. Add more content after the "Read More" block

## Expected behaviour

I would expect to see the "Continue Reading" link.

## Actual behaviour
There was no "Continue Reading" link, despite the fact that the post was truncated and there was more content.

## Screenshots

When using a 3 or more line paragraph before the "Read More" block (this is the expected behaviour):

When the content before the "Read More" block is too short (no "continue reading" link):

I initially noticed this with a theme called [Healty Living](https://wordpress.com/theme/healthy-living) and thought this was coming from the "More block" itself, but then I noticed that this was not happening with previous bundled themes:

## WordPress information

  • WordPress 5.6 running Twenty Twenty-One theme.
  • Gutenberg Version 9.8.1
  • Are all plugins except Gutenberg deactivated? YES
  • Are you using a default theme (e.g. Twenty Twenty-One)? YES

The error happens both with and without the Gutenberg plugin, as well as on WordPress.cmo sites.

## Device information
Desktop
MacOS 10.13.6
Google Chrome 88.0.4324.96

Attachments (6)

Screen Shot on 2021-01-25 at 14:59:58.png (348.3 KB) - added by mrfoxtalbot 3 years ago.
Screen Shot on 2021-01-25 at 14:59:45.png (592.6 KB) - added by mrfoxtalbot 3 years ago.
Screen Shot on 2021-01-25 at 15:19:44.png (910.3 KB) - added by mrfoxtalbot 3 years ago.
Screenshot 2021-01-25 222921.png (23.7 KB) - added by cprgolds 3 years ago.
Screenshot 2021-01-25 223210.png (37.0 KB) - added by cprgolds 3 years ago.
Screenshot 2021-01-25 223022.png (32.9 KB) - added by cprgolds 3 years ago.

Download all attachments as: .zip

Change History (12)

#1 @mrfoxtalbot
3 years ago

Here is a possibly related issue affecting excertps

https://core.trac.wordpress.org/ticket/52197

#2 @cprgolds
3 years ago

Interestingly, I also tried this and it seems to work as expected if the text blocks are classic paragraphs, but as reports with paragraph blocks. Images attached.

#3 @SergeyBiryukov
3 years ago

  • Summary changed from "Continue Reading" link will only show if there is minimum amount of text before the "Read More" block to Twenty Twenty-One: "Continue Reading" link will only show if there is minimum amount of text before the "Read More" block

#4 @poena
22 months ago

Hi!
I don't believe that this is a theme issue, and I suggest closing this issue.

The More block is the equivalent of the <!-- more tag, which is only displayed with the_content, not the_excerpt.
Please see https://developer.wordpress.org/reference/functions/the_excerpt/#comparison-with-the-more-quicktag
Source where the <!-- more tag is added:
https://github.com/WordPress/gutenberg/blob/trunk/packages/block-library/src/more/save.js#L11

I believe the description of the block can be miss leading:
Content before this block will be shown in the excerpt on your archives page.
Because this is only true if that archive page shows the full content, then the text displays as a custom excerpt.
It is easy to see how users may have different expectations!

5.7:

On the blog, the more block will always show in Twenty Nineteen, because the theme shows the post content, not the excerpt.

But it will only show in Twenty Twenty or Twenty Twenty-One if their theme options are set to display full content.
That is regardless of the length of the content before the more block.

In screenshot two of Twenty Twenty-One above, where the ...Continue reading text is immediately after the content, and not on a separate line: I would like to point out that this is not the block, but the themes own continue reading function. You can test that on a longer post that does not have the block.

6.0:

A new read more block was added to WordPress in version 6.0. The new block only adds a link, it does not hide content that comes after it.
Whether it shows depends on if the theme is set up to show the full content or the excerpt. If I understand correctly that is because the excerpt filters blocks (images etc) and only shows text.
For example, it will always show in Twenty Nineteen, but will only show in Twenty Twenty or Twenty Twenty-One if their theme options are set to display full content.

Last edited 22 months ago by poena (previous) (diff)

#5 @poena
12 months ago

  • Keywords close 2nd-opinion added

#6 @karmatosed
6 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I agree with your thoughts and findings @poena so will close this ticket. We can always reopen if someone else feels differently. Thank you everyone for your collaboration on this.

Note: See TracTickets for help on using tickets.