WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#52383 closed defect (bug) (invalid)

Missing JSON translation files in wordpress-5.6-hu_HU.zip

Reported by: molcsa Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description (last modified by ocean90)

I'm using latest Hungarian WordPress version (5.6 hu_HU) on my website (downloaded from here), and noticed that the block editor's display language is mainly English, however every other part of the admin panel is translated to Hungarian properly.
I deactivated all plugins, and correctly set the language to Hungarian in user settings and in WordPress admin's general settings as well, but didn't solve the issue.
I figured out that if I install the international version of Wordpress, the installer asks to select desired language during setup, and downloads the translation files correctly to wp-content/languages folder (there are .po and .mo files for php and .json files for javascript).
In contrast the Hungarian zip file already contains the languages folder, but contains only the .po and .mo files, there are no JSON files in it. This causes incomplete translation when using the website.
I solved the issue by copying the JSON files from the international install to our website's languages folder (Hungarian WP install), and the translation is now complete.
Please fix this issue, and include the JSON files in the next release of Hungarian Wordpress installer package, if possible.
Thanks in advance.

Change History (2)

#1 follow-up: @ocean90
9 months ago

  • Description modified (diff)
  • Focuses ui removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 5.6 deleted

Hello @molcsa, welcome to WordPress Trac!

Thanks for the report. This was caused by the locale team releasing the localized package manually which is no longer recommended. Preparations have be done so that new packages will include all translations files.

Since this Trac is only used for reporting issues with WordPress core directly I'm going to close this as invalid even the issue has been fixed. Thanks again.

#2 in reply to: ↑ 1 @molcsa
9 months ago

Hi @ocean90,

thank you, I'm happy that it will be solved in the next release.
And sorry for posting the issue to the wrong platform.

Replying to ocean90:

Hello @molcsa, welcome to WordPress Trac!

Thanks for the report. This was caused by the locale team releasing the localized package manually which is no longer recommended. Preparations have be done so that new packages will include all translations files.

Since this Trac is only used for reporting issues with WordPress core directly I'm going to close this as invalid even the issue has been fixed. Thanks again.

Note: See TracTickets for help on using tickets.