WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 8 months ago

Last modified 7 months ago

#52395 closed defect (bug) (reported-upstream)

Most Used Blocks not working properly

Reported by: jefftgefm Owned by:
Milestone: Priority: normal
Severity: major Version: 5.6
Component: Editor Keywords:
Focuses: ui Cc:

Description

I’m having two semi-related issues with Blocks that are really cutting into the productivity for my team and myself on our site.

1) When writing posts on our site we use with OVERWHELMING frequency the Paragraph, Heading, Custom HTML, YouTube, and Image blocks.

Yet, despite having what seems to be the appropriate box ticked in Post Editor (POST screen/ PREFERENCES/ Show most used blocks -Places the most frequent blocks in the block library) the “Most Used Blocks” sub-window that pops up when ticking the + consistently shows the same six blocks, three of which we simply never use: Embed, Twitter, and WordPress (see attached image).

Although we do A LOT of embedding, we prefer to use the Custom HTML block over the Embed block because the latter rarely works with what we are embedding, so using the Embed block is not an option.

Is there another method I should be using to ensure that the appropriate “most used” blocks that we actually use populate in that window?

Furthermore, using the Block Manager, I encounter the following issues:

1a) Attempting to disable the Embed block also completely removes the YouTube option, making this a non starter.

1b) There seems to be no means to disable the Twitter or WordPress blocks to force them not to populate.

2) Pursuant to the above, a few months ago (maybe? time is strange nowadays) an update to WordPress changed the amount of “Most Used” blocks that populated in the sub-window from, I believe, 8 or 9 down to 6. Before this change those couple of extra blocks truly covered EVERYTHING we ever use. Is there a way to return to more blocks, or alter the behavior of the sub-window to show more “Most Used” blocks?

Attachments (1)

Screen Shot 2021-01-28 at 11.22.34 AM.jpg (34.0 KB) - added by jefftgefm 9 months ago.
View of the Most Used Blocks menu that now populates

Download all attachments as: .zip

Change History (5)

@jefftgefm
9 months ago

View of the Most Used Blocks menu that now populates

#1 @sabernhardt
9 months ago

  • Component changed from General to Editor
  • Focuses accessibility performance removed

#2 @skorasaurus
8 months ago

Hi,

Thanks for reporting! The cause of this was that the the block frecency calculator was including all embed blocks (Which includes the youtube) so if you were to use one of them, all of them were displaying!

This was reported at https://github.com/WordPress/gutenberg/issues/28573

and has been fixed! It will be included in the Gutenberg 10.0 release.

#3 @skorasaurus
8 months ago

  • Resolution set to reported-upstream
  • Status changed from new to closed

Hi Jeff,

I forgot to close this yesterday; please reopen this if your concerns have been addressed in the ticket above.

#4 @desrosj
7 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.