WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 7 months ago

Last modified 7 months ago

#52398 closed defect (bug) (duplicate)

WordPress asking for me to save the page on exit without making any changes

Reported by: BackuPs Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.7
Component: Editor Keywords: needs-patch
Focuses: Cc:

Description

Hi

If i install a clean wp with only the classic editor and open a page and click somewhere in the page content and then exit the page i need to save the page although no changes have been made to the page content.

I ca not recall i had this issue before. Is this default now that one gets that annoying popup message saying that something has changed and one needs to save the page?

Please advice, thank you!

Attachments (1)

Exit-page-no-change-pop-up.gif (1.2 MB) - added by paaljoachim 7 months ago.
Popup shows up in page even when no changes have been made.

Download all attachments as: .zip

Change History (12)

#1 @BackuPs
8 months ago

it even happens on scroll when I do not click the editor on editing a page. This is very annoying. Can you please stop that behaviour on scrolling while in edit mode of a page. One needs to be able to scroll a page in edit mode just to see all it settings and metaboxes.

If i revert to wp 5.6 the issue is gone. It only happens in wp 5.7

Last edited 8 months ago by BackuPs (previous) (diff)

#2 @SergeyBiryukov
8 months ago

  • Component changed from General to Editor

This ticket was mentioned in Slack in #core-editor by paaljoachim. View the logs.


8 months ago

#4 @Django11
8 months ago

Confirmed, its make content editors mad!

#5 @paaljoachim
7 months ago

  • Keywords needs-patch added

Testing:

Theme: Twenty Twenty One.
Plugins activated: Classic Editor and WordPress Beta Tester

  1. Open a site running the beta version of WordPress 5.7. (Use the WordPress Beta Tester plugin)

Under Tools -> Beta Testing. Select Bleeding edge. Then update to 5.7 in the update screen.

  1. Install the Classic Editor plugin.
  2. Go to a page.
  3. Click around in the screen, but make no changes.
  4. Exit the screen. Notice popup message mentioning "Changes to made may not be saved"

The bug: A popup message should not show up when exiting a page when no changes have been made. .

---

Theme: Twenty Twenty One.
Plugins activated: Classic Editor

I am seeing the same results in WordPress 5.6.1.
It is also here only affecting a page.

NB**
Opening a post in 5.6 and 5.7 and clicking around without adjusting anything no popup is seen when exiting the screen.

@paaljoachim
7 months ago

Popup shows up in page even when no changes have been made.

This ticket was mentioned in Slack in #core by paaljoachim. View the logs.


7 months ago

#7 @SergeyBiryukov
7 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report! This is already fixed in [50232] / #52440.

#8 @paaljoachim
7 months ago

Thanks @SergeyBiryukov
That is nice to know about.
Have a great continued weekend!

#9 @paaljoachim
7 months ago

I have seen a client have a similar issue using Gutenberg. Where she clicked around and made no change and when she went to exit the popup showed up asking to save. I have had a hard time replicating the issue.

#10 @paaljoachim
7 months ago

Multiple comments in this Classic Editor support forum which report similar problems:
https://wordpress.org/support/topic/save-popup-seen-even-in-page-with-no-changes-made/

I have though also seen it in a Gutenberg page/post.

Last edited 7 months ago by paaljoachim (previous) (diff)

This ticket was mentioned in Slack in #core by paaljoachim. View the logs.


7 months ago

Note: See TracTickets for help on using tickets.