WordPress.org

Make WordPress Core

Opened 14 years ago

Closed 14 years ago

#5241 closed defect (bug) (worksforme)

Embedding Stage6 Video Inserts <br> tag and breaks all themes.

Reported by: Manthem86 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3
Component: Administration Keywords: stage6, divx, embed
Focuses: Cc:

Description

Embedding of DiVX Stage6 videos at http://stage6.divx.com/videos/ using the DiVX web embed tool at http://labs.divx.com/WebPlayerCodeGenerator inserts a <br> tag which causes the theme to break. I've tested this on multiple themes and they all had the same result.

Below is what the code should look like, followed by the outputted code from WP.

Desired Code:

<object codebase="http://" height="576" width="720" classid="clsid:67DABFBF-D0AB-41fa-9C46-CC0F21721616"><param name="autoplay" value="false">

Actual Code:

<object codebase="http://" height="544" width="960" classid="clsid:67DABFBF-D0AB-41fa-9C46-CC0F21721616"><BR/><param name="autoplay" value="false">

Change History (1)

#1 @Viper007Bond
14 years ago

  • Component changed from General to Administration
  • Resolution set to worksforme
  • Status changed from new to closed

This code works fine for me:

<object><param name="foo" value="bar" /></object>

It ends up as this:

<p><object>
<param name="foo" value="bar" /></object></p>

Remove all line breaks from your code, i.e. don't have this:

<object>
<param name="foo" value="bar" />
</object>

because that would add in <br /> as intended (you have a line break there, so you must "want" a <br />.

Also make sure to not use the RTE editor (i.e. paste into the "Code" tab or disable it altogether).

Note: See TracTickets for help on using tickets.