Make WordPress Core

Opened 3 years ago

Closed 17 months ago

#52423 closed defect (bug) (duplicate)

Editing a category or a tag, and getting error message "You need a higher level of permission. Sorry, you are not allowed to edit this item."

Reported by: webtechimt's profile webtechIMT Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.6
Component: Taxonomy Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

I'm using WordPress multi-sites and in one of the 300 sites when I want to edit a category or a tag, I get error message "You need a higher level of permission. Sorry, you are not allowed to edit this item."

As I saw in the bug #46297, I used the plugin wp-find-shared-terms (https://github.com/jjeaton/wp-find-shared-terms) and click "Split shared items" button, but it splits none :

Splitting all shared terms
Process complete!
Processed: 42
Split: 0
Skipped: 42
Errors: 0

And the bug remains when I want to edit a category (I get the error message "You need a higher level of permission. Sorry, you are not allowed to edit this item.").

Change History (7)

#1 @sabernhardt
3 years ago

  • Component changed from General to Taxonomy
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

@webtechIMT I copied part of the description into your last comment on #46297. I'm closing this separate ticket to keep the discussion there.

#2 @webtechIMT
3 years ago

@sabernhardt OK, but no one is answering to #46297... I need help...
Could help wake up this old ticket in order to solve it ?

Last edited 3 years ago by webtechIMT (previous) (diff)

#3 @webtechIMT
2 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Hello,

I still have the bug...
No one is answering to #46297.

Is there anybody out there ?

#4 @vijayhardaha
2 years ago

Try this solution on a staging website
https://stackoverflow.com/a/44175853/11848895

Found this comment, describing the similar solutions and problems from database entries
https://wpml.org/forums/topic/updating-failed-sorry-you-are-not-allowed-to-assign-the-provided-terms/#post-7826535

Last edited 2 years ago by vijayhardaha (previous) (diff)

#5 @SergeyBiryukov
2 years ago

  • Description modified (diff)

#6 @webtechIMT
2 years ago

Thank you,

But when you try the solution described in https://stackoverflow.com/a/44175853/11848895, you lose data:
For example, I have the bug with a category A and a tag with the same name A and I have to choose wich one I have to deleted to solve the bug.
If I choose for example to delete the tag, I lose association of all my posts with the tag A...

Is there any solution without losing data ?

#7 @sabernhardt
17 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #46297.

Re-closing as a duplicate.

If you still have trouble with this, please use the support forum.
https://wordpress.org/support/forum/wp-advanced/

Note: See TracTickets for help on using tickets.