WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 5 months ago

Last modified 5 months ago

#52437 closed defect (bug) (invalid)

Excerpts don't have spaces between sentences if there is a paragraph break in the original content

Reported by: larssg Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.6
Component: Editor Keywords:
Focuses: Cc:

Description

If a post has a paragraph after a short first sentence, the excerpt will likely contain that first sentence then the next sentence without a space between the two sentences (like this.Next sentence).
To fix this, why not simply replace <p>, <br> and other tags that create a line break with &nbsp; when creating the excerpt?

Change History (5)

This ticket was mentioned in Slack in #core by peterwilsoncc. View the logs.


5 months ago

This ticket was mentioned in Slack in #core by peterwilsoncc. View the logs.


5 months ago

#3 @peterwilsoncc
5 months ago

  • Component changed from General to Editor
  • Keywords reporter-feedback added

Hi @larssg and welcome to trac!

This was discussed in a triage session today.

I wasn't able to reproduce the issue when entering content in either the classic or block editor. In both cases, a space is placed between paragraphs for auto-generated excerpts.

Are you able to provide some additional steps to help reproduce the issue.

Thanks.

#4 @larssg
5 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I can't reproduce this any more either.

#5 @peterwilsoncc
5 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted

Thanks for following up so quickly.

I'll do a quick search shortly to see if it was fixed on another ticket in the last few months and add a follow up comment if I can find the relevant change.

Note: See TracTickets for help on using tickets.