WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#52446 closed defect (bug) (duplicate)

Issue with custom post types and classic editor - "Changes you made may not be saved"

Reported by: tonysandwich Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

Since upgrading yesterday to 5.6.1, any time I try to edit a custom post type without the Gutenberg editor enabled in the supports array of the custom post type I get a "Changes you made may not be saved" alert, even if I did not make any changes, or even if the post has been published.

Enabling Gutenburg in supports fixes this issue, however if I enable the Gutenburg editor, and then install the classic editor plugin I get the same alert each time I try and navigate away from the post editor screen.

I have reverted back to 5.6 and everything works as it should.

Change History (2)

#1 @vladytimy
2 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #52440.

Hi there! Thanks for reporting this!

This issue has already been reported, and is being tracked in 52440

#2 @SergeyBiryukov
2 months ago

  • Component changed from General to Editor
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.