WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 7 months ago

Last modified 7 months ago

#52449 closed defect (bug) (fixed)

Can't change font size with 5.6.1 paragraph block

Reported by: sterndata Owned by: desrosj
Milestone: 5.6.2 Priority: normal
Severity: major Version: 5.6.1
Component: Editor Keywords:
Focuses: Cc:

Description

If I select a font size from the dropdown, it just reverts to "default". This seems to be a 5.6.1 issue. There are at least a couple of reports of this in the forums.

https://www.loom.com/share/56fd0d20ac92477bb364aa2c1866c171

Attachments (1)

patch.diff (996 bytes) - added by inc2734 8 months ago.

Download all attachments as: .zip

Change History (20)

#1 @SergeyBiryukov
8 months ago

  • Milestone changed from Awaiting Review to 5.6.2

#3 follow-up: @hellofromTonya
8 months ago

Related to #52431 where a fix is ready for Twenty Twenty-One theme.

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


8 months ago

#5 @mwhiteley16
8 months ago

Is this specific to Twenty Twenty-One theme? I'm having this issue in 5.6.1 on all the sites I test (I use Genesis and register custom font sizes using add_theme_support editor-font-sizes).

#6 @hellofromTonya
8 months ago

Thank you for providing more information @mwhiteley16! It does appear to be a regression.

#7 @sterndata
8 months ago

This happens on twentyfourteen, as well, so I think it's a fairly general issue.

#8 @tmphoto2
8 months ago

This happened to me on my site using a different theme - All text which had been changed reverted back to default size and could not be edited by selecting different sizes. I contacted my host who rolled WordPress back to 5.5.3 and i can now edit text again! Good luck.

Last edited 8 months ago by tmphoto2 (previous) (diff)

@inc2734
8 months ago

#9 @inc2734
8 months ago

The reason why the text size is not reflected in the choices is that the first argument of min() is missing px.

The reason why the text does not reflect the font size when you select an option is that it refers to selectedItem.style.

For the first problem, I threw a pull request to Gutenberg.
https://github.com/WordPress/gutenberg/pull/28761

The second problem has probably been fixed in the latest version of Gutenberg.

#10 @duncan1967
8 months ago

Confirmed happens on Astra as well. Tested on two different WordPress 5.6.1 installations using different themes.

Workaround: manually adding the required style in the block's "Advanced - Additional CSS" (e.g. has-medium-font-size for medium fonts) displays correctly on the front end, but the change is not visible in Gutenberg.

#11 @juanwp22
8 months ago

Good morning, the problem persists, is there any temporary solution?

#12 in reply to: ↑ 3 @SergeyBiryukov
8 months ago

Replying to hellofromTonya:

Related to #52431 where a fix is ready for Twenty Twenty-One theme.

Just to clarify, that Twenty Twenty-One ticket is about the code block and this one is about a regression in the paragraph block in 5.6.1, so I don't think they are related.

#13 @lurmadec
8 months ago

I'm using a child theme of Olsen-Light and am experiencing the same issue. If I try to change the font size to "Medium" it reverts back to "Default". As a workaround, I found if I enter 20 in the "Custom" pulldown, the font field changes to "Medium".

#14 @SergeyBiryukov
7 months ago

#52507 was marked as a duplicate.

#15 @SergeyBiryukov
7 months ago

#52508 was marked as a duplicate.

#16 @squarecandy
7 months ago

I also experienced this today trying out Gutenberg with a custom theme that was built around 4 years ago. Same as @lurmadec - the custom size number field works, but not the small/med/large/etc drop down. And if you hit the exact number for the named size, it fills it in.

#17 @audrasjb
7 months ago

#52522 was marked as a duplicate.

#18 @desrosj
7 months ago

  • Owner set to desrosj
  • Resolution set to fixed
  • Status changed from new to closed

In 50376:

Editor: Update block editor dependencies for 5.6.2.

This updates several packages to their latest patch versions to fix bugs discovered in the 5.6 branch.

@wordpress/block-directory to 1.17.8
@wordpress/block-editor to 5.1.7
@wordpress/block-library to 2.26.8
@wordpress/components to 11.1.5
@wordpress/core-data to 2.24.4
@wordpress/edit-post to 3.25.8
@wordpress/editor to 9.24.7
@wordpress/format-library to 1.25.7
@wordpress/list-reusable-blocks to 1.24.5
@wordpress/media-utils to 1.18.1
@wordpress/nux to 3.23.5
@wordpress/reusable-blocks to 1.0.7
@wordpress/server-side-render to 1.19.5

Props isabel_brison, talldanwp, youknowriad, freewebmentor, sterndata, inc2734, itsjonq, jorgefilipecosta, aristath, nosolosw, mattwiebe, addiestavlo, kevin940726, noisysocks, aaronrobertshaw, glendaviesnz, gwwar, bernhard-reiter, paaljoachim.
Fixes #52396, #52449, #52553.

#19 @desrosj
7 months ago

#52602 was marked as a duplicate.

Note: See TracTickets for help on using tickets.