WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#52455 closed enhancement (fixed)

Update the `package.json` `engines` to contain a version range

Reported by: desrosj Owned by: desrosj
Milestone: 5.7 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords:
Focuses: Cc:

Description

The engines field in the package.json file specifies the desired versions of NodeJS and (optionally) NPM.

The build server uses the node version specified here to determine which version of NodeJS to use when building WordPress after a commit. Until recently, this did not support version ranges (see https://make.wordpress.org/systems/2021/01/27/core-build-sync-node-version-selection/).

Specifying a range can make it more obvious to contributors that any version of Node >= the latest LTS version (currently 14.x) can be used, and not just the one specific version that has been specified previously.

trunk should be updated to specifify node >=14.15.0 and npm >=6.14.8.

Change History (2)

#1 @desrosj
8 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 50185:

Build/Test Tools: Specify a version range within engines for node and npm.

This makes it more clear what versions of node and npm will successfully build WordPress.

Props dd32, mkaz.
Fixes #52455. See #51749.

#2 @desrosj
8 months ago

In 50186:

Build/Test Tools: Specify a version range within engines for node and npm.

This makes it more clear what versions of node and npm will successfully build WordPress.

Props dd32, mkaz.
Merges [50185] to the 5.6 branch.
Fixes #52455. See #51749.

Note: See TracTickets for help on using tickets.