WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 35 hours ago

Last modified 29 hours ago

#52462 closed enhancement (duplicate)

Allow Custom Taxonomy Help Text Labels for All Fields

Reported by: dshanske Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords:
Focuses: ui Cc:

Description

In the add/edit screen for taxonomies, the fields for name, slug, parent, and description have a help text below them. For example, "Assign a parent term to create a hierarchy. The term Jazz, for example, would be the parent of Bebop and Big Band."

Suggest this be added to the Taxonomy Labels that are set when the taxonomy is registered, so you can describe how these fields are used specifically in your custom taxonomy.

This has the benefit of eliminating the special casing in edit-tags.php for category only, allowing that to be registered properly.

Change History (2)

#1 @dshanske
35 hours ago

  • Milestone changed from Awaiting Review to 5.9
  • Resolution set to fixed
  • Status changed from new to closed

This seems like it is addressed in 5.9, according to https://make.wordpress.org/core/2021/12/13/posts-post-types-and-taxonomy-changes-in-wordpress-5-9/, referencing ticket #43060

Resolved in [52094]

#2 @SergeyBiryukov
29 hours ago

  • Keywords needs-patch removed
  • Milestone 5.9 deleted
  • Resolution changed from fixed to duplicate

Duplicate of #43060.

Note: See TracTickets for help on using tickets.