Make WordPress Core

Opened 3 years ago

Last modified 19 months ago

#52464 reviewing defect (bug)

The value of argument passed to the update_option_new_admin_email() is not a valid email.

Reported by: tremidkhar's profile tremidkhar Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Networks and Sites Keywords: has-patch needs-unit-tests needs-testing needs-testing-info reporter-feedback
Focuses: multisite Cc:

Description

While creating a patch for ticket #43706, I found out that the function update_option_new_admin_email() is responsible for the template. It does accept two parameters, however, the first parameter $old_value does not seem to get the correct value.

When checking the value, it holds the value new_admin_email instead of the old email address.

Thanks!

Change History (13)

#1 @sabernhardt
3 years ago

  • Component changed from General to Networks and Sites
  • Focuses multisite added

This ticket was mentioned in PR #1014 on WordPress/wordpress-develop by tremidkhar.


3 years ago
#2

  • Keywords has-patch added

When changing the admin email address, the argument passed to update_option_new_admin_email() function is a string instead of an email address.

Trac ticket: https://core.trac.wordpress.org/ticket/52464

This ticket was mentioned in Slack in #core by sergey. View the logs.


3 years ago

#4 @SergeyBiryukov
3 years ago

  • Milestone changed from Awaiting Review to 5.8
  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing

This ticket was mentioned in Slack in #core by chaion07. View the logs.


3 years ago

#6 @chaion07
3 years ago

Thanks to @tremidkhar for reporting this. We reviewed this ticket during a recent [bug-scrub session]https://wordpress.slack.com/archives/C02RQBWTW/p1623098372373600. With Beta 1 coming in a day, checking with @SergeyBiryukov to kindly draw some attention to this. Thank you!

#7 @hellofromTonya
3 years ago

  • Milestone changed from 5.8 to 5.9

Today is 5.8 Beta 1. With no activity, punting to 5.9.

#8 @hellofromTonya
2 years ago

  • Keywords needs-unit-tests needs-testing needs-testing-info reporter-feedback added
  • Milestone changed from 5.9 to 6.0

Hello @tremidkhar,

Welcome to WordPress Core Trac!

First of all, I'm sorry your ticket and patch has not yet been reviewed, but rather punted from release to release.

Can you please provide step-by-step instructions on how to reproduce the reported problem? First step will be to reproduce it and then dive in to investigate why it's happening. Marking the ticket for needs-testing-info.

Also, if a new function is what's needed, it will require unit tests. Marking the ticket to note that need.

With 5.9 Beta 1 in 2 days and no activity (yet) on this ticket, moving it to 6.0. However, if the problem is reproducible and the patch is ready, then it can be moved back into the 5.9 milestone for commit consideration. Else, let's see if it can be resolved in 6.0.

This ticket was mentioned in Slack in #core by mike. View the logs.


2 years ago

#10 @hellofromTonya
2 years ago

  • Milestone changed from 6.0 to Awaiting Review

As 6.0 RC1 is tomorrow and there's been no activity since it was punted from 5.9, moving this back to Awaiting Review.

#11 @tremidkhar
19 months ago

Hello @hellofromTonya,

I apologize for the delay, Here is a video on how to reproduce the issue that I have mentioned.

https://youtu.be/tvKBLnx6VfI

TremiDkhar commented on PR #1014:


19 months ago
#13

Closing this as the dev branch is out of date.

Opening a new PR here.

Note: See TracTickets for help on using tickets.