WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 7 months ago

#52498 closed defect (bug) (reported-upstream)

"Norsk nynorsk" language leads to double spaces in all content output

Reported by: heintore Owned by:
Milestone: Priority: normal
Severity: minor Version: 5.6.1
Component: I18N Keywords:
Focuses: Cc:

Description

If you set the WordPress language to Norwegian nynorsk (no_NN), the content output through templates and the Rest API has double spaces in it.

I know this sounds like a strange and very specific bug, but it's easy to reproduce:

  1. Set the WordPress language in general settings to "Norsk nynorsk"
  2. Go visit a random post or page at the site, and inspect/view the source. Alternatively you can do a GET request for posts using the Rest API
  3. Watch how the titles and content have double spaces in them

The bug can be reproduced on all sites, regardless of what theme and plugins you have activated.

Switching to a different language fixes the problem. I guess the language pack somehow is at fault?

The problem has been present for quite a while, so it's not new in 5.6.x.

For now, I'd be really interested in a workaround as switching the language on the affected sites is not an option.

Change History (6)

#2 @heintore
8 months ago

Thank you, @tobifjellner!

I'm not too familiar with translations. Is there an easy/obvious fix to this that can be committed?

#3 @tobifjellner
8 months ago

I believe that I've already fixed the root issue in the current translation. However, the #nn_NO team would need to catch up and reach 100% translated status in all four projects in https://translate.wordpress.org/locale/nn/default/wp/dev/ where some 800 strings are lagging behind.
In other words, we need volunteer translators that know Nynorsk well. If you want to help, then you could start submitting strings. It would be good to first get in touch with the General Translation Editors, listed in https://make.wordpress.org/polyglots/teams/?locale=nn_NO in order to make sure that you avoid various generic problems/errors. As you can, see, some of them can be reached via Slack.

#4 @meinmycell
8 months ago

I wasn't aware of this error. Does @tobifjellner's change fix the issue? If so, @heintore could mark the bug as resolved.

A bigger problem is that the Nynorsk translation indeed is behind. There are few active translators. I have been the only consistently active translator for years, but I am lagging behind now because of lack of time. The translation will be brought up to 100% eventually, but it will take time. We could definitely use some help.

#5 @tobifjellner
8 months ago

  • Resolution set to reported-upstream
  • Status changed from new to closed

@heintore
You can verify that it will be fixed if you do the following:

  1. Go to https://translate.wordpress.org/projects/wp/dev/nn/default/

At the end of the page, select to export "all current strings" as an .mo file.

  1. Rename the file into nn_NO.mo and upload it to /wp-content/languages/nn_NO.mo
  1. Go to Settings → General; change site language to "English (US)" and then back to "Norsk Nynorsk"

now it should be correct.

So I'm going to close this ticket since we now know for sure that this is no core bug.

And: once the translation reaches 100%, then this corrected version will get packaged (within 1-2 hours) and distributed automatically to all relevant sites.

#6 @desrosj
7 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.