WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 5 months ago

Last modified 3 months ago

#52532 closed feature request (reported-upstream)

Accessibility improvement request: The add block (plus mark) is missing at the top of the first block and the line isn't clickable so we have to mouse over a tiny 24 pixel square.

Reported by: a4jp.com Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.6.1
Component: Editor Keywords:
Focuses: ui, accessibility, coding-standards Cc:

Description

Can you make

div.block-editor-block-list__insertion-point.is-vertical

clickable and add the insert block option when you mouse over the top of the first block please? The add block option is missing now. We have to add a block below the first block then move it up everytime instead of just adding a block at the top. All the other positions are okay. Just the first one is missing.

I think these two tiny tweaks would make WordPress a lot easier to use and improve accessibility.

The clickable button

button.components-button.block-editor-inserter.toggle.has-icon

is only 24 by 24 pixels in size making it difficult to click. If the line was clickable it would easily increase the height of the clickable area to 28 pixels without any big changes and the width would be the whole line. This would finally save us from moving the cursor to that tiny 24 pixel spot.

Thank you for all the other accessibility improvements you have made version by version. It is a lot easier to make websites now.

Change History (14)

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


7 months ago

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


6 months ago

#3 @quadthemes
6 months ago

  • Severity changed from major to normal

@a4jpcom

Regarding the first issue, it seems like the issue is likely with WordPress Twenty Twenty theme itself rather than Gutenberg.
It would be great if you can confirm that you are able to see the +(plus icon) when you're using another theme.

Check issue #49610 for the reference

Last edited 6 months ago by quadthemes (previous) (diff)

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


6 months ago

#5 @ryokuhi
6 months ago

  • Keywords needs-testing reporter-feedback added

#6 @quadthemes
6 months ago

@a4jpcom @ryokuhi
Created an issue at Gutenberg repo for the second issue. Let me know if you've any issues.

Here is the link to the issue: https://github.com/WordPress/gutenberg/issues/30041

#7 @a4jp.com
6 months ago

Anything that helps is good. @ryokuhi and @quadthemes thank you.

#8 @a4jp.com
6 months ago

@quadthemes I have the same problem on about 10 different sites with custom made themes as well as other just downloaded from WordPress.

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


6 months ago

#10 @joedolson
6 months ago

  • Milestone changed from Awaiting Review to Future Release

#11 @quadthemes
6 months ago

@ryokuhi
Created 2nd issue at gutenberg repo for the first issue. I was able to reproduce the error.

Here is the link to that: https://github.com/WordPress/gutenberg/issues/30470

#12 @talldanwp
5 months ago

  • Keywords needs-testing reporter-feedback removed
  • Milestone Future Release deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Closing as this has been reported and is being tracked on the Gutenberg github repository.

It'd be great to move all further conversation over to there.

#13 @a4jp.com
3 months ago

Okay.
Thank you @talldanwp
Is this https://github.com/WordPress/gutenberg/issues/30470 the place we should go?

#14 @talldanwp
3 months ago

@a4jpcom Yep, that's the place.

Note: See TracTickets for help on using tickets.