Make WordPress Core

Opened 3 years ago

Closed 5 weeks ago

#52634 closed defect (bug) (worksforme)

Twenty Twenty: Child Theme Search Modal Safari Throws Error in Parent asset/index.js

Reported by: wp89mkt's profile wp89mkt Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Bundled Theme Keywords: reporter-feedback close
Focuses: javascript Cc:

Description

Twenty Twenty child theme, search modal on safari throws error in parent asset/index.js when search toggle clicked. Works fine in all other browsers.

TypeError: null is not an object (evaluating 'modal.querySelectorAll')

elements = modal.querySelectorAll( selectors );
null is not an object (evaluating 'modal.querySelectorAll')

Change History (6)

#1 @sabernhardt
3 years ago

  • Component changed from General to Bundled Theme
  • Summary changed from Twenty Twenty Child Theme Search Modal Safari Throws Error in Parent asset/index.js to Twenty Twenty: Child Theme Search Modal Safari Throws Error in Parent asset/index.js

#2 @sabernhardt
3 years ago

  • Focuses javascript added
  • Keywords reporter-feedback added
  • Version changed from 5.6.2 to 5.3

Thanks for the report!

That line is in the keepFocusInModal function. Both search buttons should have the data-toggle-target=".search-modal" attribute, but it might help to know if this error occurs when clicking either the desktop or mobile search toggle button (or both).

#3 @karmatosed
8 weeks ago

@sabernhardt did you also get the error? I was unable to replicate using Safari so wondering if it isn't an issue now or I might be missing a step to reproduce.

#4 @sabernhardt
7 weeks ago

No, I did not test with Safari (if at all) years ago. I usually use Windows and have not booted up my old Mac to test this in the past few days either.

#5 @karmatosed
6 weeks ago

  • Keywords close added

Okay, I am unable to reproduce, so I recommend we close this with an option to reconsider if more information comes up. Thank you, everyone, for your collaboration so far.

#6 @karmatosed
5 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thank you everyone for your collaboration, I am going to progress this to close now.

Note: See TracTickets for help on using tickets.