WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#52650 closed defect (bug) (duplicate)

Media dialog throws away models in query cache and I get a blank media view

Reported by: devowl Owned by:
Milestone: Priority: normal
Severity: major Version: 5.6.2
Component: Media Keywords:
Focuses: ui, javascript Cc:

Description

Reprocedure as follows:

  1. Upload 3 images your media library
  2. Create a post and click "Set featured image"
  3. 3 files are visible
  4. Filter by "Date", e.g. select this month
  5. 3 files are visible
  6. Change filter back to "All dates"
  7. Close media dialog
  8. Click on "Set featured image" again (do not reload the page**)
  9. Filter by "Date" again and select the previously selected month
  10. You will not get any images in the view

Reprocedure video: https://drive.google.com/file/d/1iT4Dve5fn8lxoChCPOWaajhs4FPQN2Yr/view

Notes:

  • This issue is not related to Gutenberg because all media dialogs are affected
  • It also is not only related to the "Date" filter, the same issue can be reprocedured with all filters (e.g. "Unattached")
  • It is not related to any plugin because I have deactivated all plugins and themes (using default theme)
  • Not reprocedurable in WordPress 5.5 (tested on another customer installation)

I could identify that the following line https://github.com/WordPress/WordPress/blob/dc3a76e8f325e05eca7534babf9e42cdc14bb5bd/wp-includes/js/media-models.js#L1376 shows a query cache without models length=0 and hasMore=false.

Change History (2)

#1 @Mista-Flo
4 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #50025.

Hi @devowl, you had a nice catch indeed.

It was an issue raised 10 months ago, and fixed a few weeks ago, it will be available in the next 5.7 which will be probably available next month.

#2 @SergeyBiryukov
4 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.