WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#5266 closed defect (bug) (duplicate)

Removal of more PHP Warnings

Reported by: Viper007Bond Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3
Component: Administration Keywords: has-patch 2nd-opinion
Focuses: Cc:

Description

I'm using /wp-admin/includes/admin.php and /wp-admin/menu.php from outside of the admin area (to get a list of menu items). Doing so generates a PHP error.

Attached patch should fix it. Logic needs a looking at though to make sure I didn't break anything.

Attachments (1)

5266.patch (820 bytes) - added by Viper007Bond 6 years ago.

Download all attachments as: .zip

Change History (4)

Viper007Bond6 years ago

comment:1 Viper007Bond6 years ago

Er, doing so generates a PHP warning, not an error.

comment:2 lloydbudd6 years ago

  • Milestone changed from 2.3.2 to 2.5

comment:3 jacobsantos6 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This most likely was fixed with another notices patch. I think there should only be one ticket for notices and warnings fixes per WordPress version.

Note: See TracTickets for help on using tickets.