WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#5268 closed enhancement (invalid)

Option to Hide Update Notification

Reported by: cpoteet Owned by:
Milestone: Priority: low
Severity: minor Version: 2.3
Component: Administration Keywords: dev-feedback
Focuses: Cc:

Description

The notification that WordPress is available to update is helpful, but only the first few times you see it. After that, it's just annoying. I know why it's there, but can't there be the option to hide the message?

This could apply to the plugin page, but I'm more concerned about the high-level message.

Change History (10)

comment:1 foolswisdom6 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

No, more options are bad.

If you want to create a new ticket that reads as a statement of problem and possible solutions, attaching code that dismisses it for a reasonable amount of time or some other solution that you find is consistent with experience expectations that would be wicked good.

comment:2 rob1n6 years ago

  • Milestone set to 2.4
  • Resolution wontfix deleted
  • Status changed from closed to reopened

More options are bad? Are you kidding me?

The user should be able to hide the message -- they could have reasons for not upgrading.

Setting milestone to 2.4, but something in the 2.3 branch would probably be better.

comment:3 foolswisdom6 years ago

  • Milestone changed from 2.4 to 2.5

-1

I was semi-joking, though more options are bad, particularly in the absense of a wholistic design.

The original problem with this ticket is focus on a solution instead of problem.

It doesn't pass the 80/20 test to me. Plugin material.

Milestone returned to 2.5 as 2.4 are for tickets with devel ownership or a patch.

comment:4 cpoteet6 years ago

  • Cc cpoteet added
  • Milestone changed from 2.5 to 2.4

Fool - You were quite rude. I think it's a perfectly acceptable suggestion. Before I went off and started working on it, I want to make sure other's agree.

comment:5 Viper007Bond6 years ago

  • Milestone changed from 2.4 to 2.5

Definitely plugin territory.

And this needs to stay 2.5.

comment:6 follow-ups: rob1n6 years ago

Am I the only one that seems to think that having a little "x" button to hide that message is not bloat and should have been in WP to begin with?

comment:7 DD326 years ago

Am I the only one that seems to think that having a little "x" button to hide that message is not bloat and should have been in WP to begin with?

A Option to ignore an update IS something that should be included IMO.

But I have to agree about disabling might as well be left to a Plugin, Theres only a few people who *need* to disable it, And those who do are more likely to understand WP more. Its a simple 3 or so line plugin to deactivate the update checks.

comment:8 in reply to: ↑ 6 cpoteet6 years ago

  • Milestone changed from 2.5 to 2.4

Replying to rob1n:

Am I the only one that seems to think that having a little "x" button to hide that message is not bloat and should have been in WP to begin with?

Agreed, and that what the ticket is about. I understand that disabling them completely should be seen as plugin territory. I'm moving it back to 2.4, but it should be something done the 2.3 branch.

Is the best way to do this simply add a record in the db after hiding them message and do a boolean check to show/hid the message?

comment:9 in reply to: ↑ 6 foolswisdom6 years ago

Replying to rob1n:

Am I the only one that seems to think that having a little "x" button to hide that message is not bloat and should have been in WP to begin with?

This ticket is bad humor to me, and the cause is as I describe. Good discussions happen when there is clear separation of problem and solution. Where people can first agree on the problem, and then they can agree on a solution.

Your current proposal sounds an awful lot like what I was suggesting might be a solution, "dismisses it for a reasonable amount of time".

I'm not sure about the "rhetoric" about "have been in WP to begin with" -- code talks, and we can't ship what isn't written.

comment:10 lloydbudd6 years ago

  • Milestone 2.5 deleted
  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.