WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 7 weeks ago

#52687 closed defect (bug) (reported-upstream)

Unable to edit blocks once they've been inserted while using screen reader

Reported by: arush Owned by: alexstine
Milestone: Priority: normal
Severity: critical Version: 5.6.2
Component: Editor Keywords:
Focuses: accessibility, multisite Cc:

Description

When adding content to a site running WordPress 5.6.2, unable to edit blocks after they've been inserted. Specifically, content within blocks. This has been tested using Jaws for Windows version 2021, 2020, and 2019, NVDA version 2020.4, latest version of Microsoft Narrator which ships with Windows 10, Firefox 86.0 and Chrome 88. Steps to reproduce: Go to the "new post", "new page", or "edit post" and "edit page" screens. Insert some blocks, or try to edit blocks that are already there. When attempting to edit by moving around with a keyboard, Jaws and NVDA say nothing at all, and text is not edited. It's as if there's no field when in forms/browse mode. Narrator reports that there is no text to be selected.

Change History (7)

#1 @alexstine
7 weeks ago

  • Owner set to alexstine
  • Status changed from new to accepted

Hello @arush

I could not replicate the same in 5.6.2.

Whenever I use NVDA, these are the steps I use to edit blocks.

  1. Open a post/page.
  2. Focus in the first edit field which is title.
  3. Switch to focus mode.
  4. Press Tab.

At this point 1 of 2 things is going to happen. Either you will land in the first blocks edit field or you will land on the first blocks button. If in the edit field, you can start editing. If on the button, press Enter to activate and you will be taken to the edit field of the block. Pressing Escape puts you back in navigation mode which is a Gutenberg mode, not a screen reader mode. Navigation mode means you can use Tab and Arrows to navigate the blocks list which is made of buttons and edit mode means you can edit a blocks content.

Hope it helps. If not, could you please try to describe in more detail what you are running in to?

Thanks.

#2 @arush
7 weeks ago

Hi @alexstein,

I'm not referring to inserting a block. I'm referring to editing a block's text after it's been inserted. While using a screen reader, use your keyboard to navigate to the title field for the post/page, press enter to enter forms mode, then tab and add a block like you normally would. Make some sort of mistake that needs to be edited. While in your screen reader's edit mode, which is how you edit text within fields on the web, try to use your keyboard's highlighting keys (ctrl+left or right arrow for words, plain arrows for characters, shift+ctrl+arrows to select for text deletion). There's no speech feedback so that you can edit text. Only workaround at this point is to type your text and correct it in something outside of the editor and then paste it in and hope there are no mistakes that need correcting once it's in there.

#3 @arush
7 weeks ago

@Alexstein Narrator is reporting "unable to take focus" when attempting to edit text within blocks. This means that the screen reader, (or any other assistive tech for that matter), is unable to programmatically gain focus. If need be I can take this discussion over to GitHub because there was a related issue on this filed back in August. The product designer is going to hate this, but is there any way you guys can add back the focus outline that was removed just before the WP 5.6 release?

#4 @alexstine
7 weeks ago

Hey @arush

So I just tried to edit a block and navigate around in NVDA focus mode using CTRL+Arrows and CTRL+Shift+Arrows to select. I also moved around with Arrows character by character and in all situations heard the text, words, and selections being announced.

Generally TRAC is not for Gutenberg and it is always best to open GitHub issues in https://github.com/wordpress/gutenberg

I recommend you open one issue for describing your difficulty editing inside blocks and another issue for the missing outline.

Once you open those, if you want to drop both links here in a comment, that would be great.

Just because I can't replicate your issue doesn't mean it doesn't exist. I am sure others are having the same issue and maybe they haven't come forward to report yet.

Thanks for reporting. Alex

#5 @arush
7 weeks ago

Hey @Alexstein, would you mind doing a Zoom meeting tomorrow afternoon so I can screen share and show you what's happening? I can reproduce this on two separate computers and I'm not familiar with a separate edit mode native to the editor. I'll also file these on GitHub as two separate issues, because I can tell you now that WordPress trying to maintain some separate edit mode of its own in order to try to avoid standard things like not-pretty focus outlines is going to be a very bad idea. If you can meet shoot me a private message on Slack and we can set this up.

#6 @arush
7 weeks ago

Going to move this ticket over to GitHub, but sitting in a zoom with Alex and we have reproduced the issue while using Jaws and NVDA.

#7 @alexstine
7 weeks ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.