WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#52693 closed defect (bug) (fixed)

White line on the image in about.php

Reported by: tmatsuur Owned by: ryelle
Milestone: 5.7 Priority: normal
Severity: normal Version: 5.7
Component: Help/About Keywords: close
Focuses: Cc:

Description

There seems to be a white line in "A Simpler Default Color Palette" in the /wp-admin/about.php page.

This seems to be caused by the following points, but normally it is better not to see the white line.

html

<div class="about__image-comparison-resize">

style

.about__container .about__image-comparison-resize {
    :
    :
  border-right: 2px solid white;
}

Attachments (2)

5_7_rc1_about.png (22.5 KB) - added by tmatsuur 9 months ago.
52693-before-after.gif (6.1 MB) - added by hellofromTonya 9 months ago.
Shows before and after applying PR 1048 from Ticket 52347. Works as expected

Change History (10)

#1 @SergeyBiryukov
9 months ago

  • Component changed from General to Help/About
  • Milestone changed from Awaiting Review to 5.7

Hi there, thanks for the ticket!

It might not be clear at a glance, but this is not just a while line, it's a draggable resize bar to compare the before/after color palette. This was also brought up in comment:29:ticket:52347 and further comments on #52347.

Moving to the milestone for visibility, though per the discussion in comment:38:ticket:52347, it looks like there is no easy way to make this control more obvious. Perhaps it could be converted to a video instead.

#2 @tmatsuur
9 months ago

Thanks @SergeyBiryukov

As you pointed out, I was able to find the icon at the bottom of the image and drag it.

This gimmick is interesting.

It may be clearer if there is an explanation that encourages people to drag the icon.

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


9 months ago

#4 @ryelle
9 months ago

This should be fixed by the change in this PR, which makes the border more obvious & turns the whole thing into a handle.

@hellofromTonya
9 months ago

Shows before and after applying PR 1048 from Ticket 52347. Works as expected

#5 @hellofromTonya
9 months ago

  • Keywords close added

The above gif shows the before and after applying PR 1048. As @ryelle notes:

makes the border more obvious & turns the whole thing into a handle

The fix will be applied when ticket #52347 is committed for 5.7.

#6 @ryelle
9 months ago

  • Owner set to ryelle
  • Resolution set to fixed
  • Status changed from new to closed

In 50478:

Help/About: Iterate on the 5.7 About Page.

Adds a more obviously interactive comparison for viewing the color scheme differences. Improvements on RTL and IE11. Update strings to be more clear and consistent. Switch to the CDN for loading images.

Props sarahricker, desrosj, melchoyce, SergeyBiryukov, tikifez, clorith, marybaum, audrasjb, francina, hellofromTonya.
Fixes #52693. See #52347.

#7 @ryelle
9 months ago

In 50480:

Help/About: Iterate on the 5.7 About Page.

Adds a more obviously interactive comparison for viewing the color scheme differences. Improvements on RTL and IE11. Update strings to be more clear and consistent. Switch to the CDN for loading images.

Props sarahricker, desrosj, melchoyce, SergeyBiryukov, tikifez, clorith, marybaum, audrasjb, francina, hellofromTonya.
Reviewed by SergeyBiryukov.
Merges [50478] to the 5.7 branch.
Fixes #52693. See #52347.

#8 @tmatsuur
9 months ago

Thanks @ryelle @hellofromTonya @SergeyBiryukov .

I updated to RC2 and confirmed that the display changed.

It seems to me that "just a white line" turns into "a line with some function" and prompts the user to take action.

Note: See TracTickets for help on using tickets.