WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5273 closed defect (bug) (fixed)

some registration emails fail in 2.3.1 b/c of "callout verification"

Reported by: camner Owned by: westi
Milestone: 2.3.3 Priority: normal
Severity: normal Version: 2.3.1
Component: General Keywords: registration emails
Focuses: Cc:

Description

Registration emails sent to certain addresses where "callout verification" is enabled will fail. The following delivery failure notice will be generated:

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

t231@…

SMTP error from remote mail server after RCPT TO:<t231@…>:
host recipient_domain.com [xxx.22.96.xxx]: 550-Verification failed for <wordpress@…>
550-Previous (cached) callout verification failure
550 Sender verify failed

This was not an issue with WP 2.2, but occurs on an upgrade to 2.3.1, or a fresh 2.3.1 install with no plugins enabled and the default theme.

Attachments (2)

no-sender.php (379 bytes) - added by westi 6 years ago.
WordPress plugin to reverse the change
5273.diff (489 bytes) - added by lloydbudd 6 years ago.
Reverting #5007

Download all attachments as: .zip

Change History (19)

comment:1 westi6 years ago

  • Owner changed from anonymous to westi
  • Status changed from new to assigned

comment:2 foolswisdom6 years ago

  • Milestone changed from 2.5 to 2.4

comment:3 stitzelj6 years ago

This is a problem for me, as well. I have a multi-author blog I'm also running that takes new contributors as they come, and neither of the last two that have signed up (both since I upgraded to 2.3.1) have received their verification emails and get email server connection errors when they try to request a new email with a password.

comment:4 stitzelj6 years ago

It appears that removing the following line from wp-includes/pluggable.php solves this problem along with the one I reported in #5294:

228  $phpmailer->Sender = apply_filters( 'wp_mail_from', $from_email ); 

westi6 years ago

WordPress plugin to reverse the change

comment:5 westi6 years ago

Could you try the attached plugin to see if this also fixes the issue for you.

This should ensure you don't have to change core files

comment:6 lloydbudd6 years ago

Marked #5294 as a duplicate of this ticket.

comment:7 lloydbudd6 years ago

  • Summary changed from some registration emails fail in 2.3.1 to some registration emails fail in 2.3.1 b/c of "callout verification"

comment:8 lloydbudd6 years ago

This issue was introduced by #5007.

lloydbudd6 years ago

Reverting #5007

comment:9 follow-up: lloydbudd6 years ago

westi, in #5007 it seems everyone is in agreement that the "fix" their should be reverted. Can you check this in for trunk and and then set the milestone to 2.3.3 (in the event such a release is necessary)

comment:10 in reply to: ↑ 9 ; follow-up: bberndt6 years ago

I came to this bug report from this one:
http://trac.wordpress.org/ticket/5294

My brother and I host a few blogs at the same host. He installed a new one and noticed that emails were not being sent form it. I had recently done an upgrade, but never bothered to check to see if the emails had worked. He stared at 2.3.1, and I upgraded to 2.3.2. My emails were previously working with an early 2.1.x release.

None of the workarounds in #5294 worked for me. The no_sender.php plugin DOES appear to fix the problem, however.

I think I have the line also deleted from my pluggable.php file removed as well, currently. My brother claims that his 'request password' emails still aren't working. Do you have to have both the line removed, and the plugin?

Does Wordpress need to change something for this to work correctly out of the box, or my hosting provider? I'm fairly technically adept, and good friends with the one of the owners/ admin. there... So can get whatever other info you may need.

comment:11 in reply to: ↑ 10 ; follow-up: lloydbudd6 years ago

Replying to bberndt:

None of the workarounds in #5294 worked for me. The no_sender.php plugin DOES appear to fix the problem, however.

That does not programmatically make sense. no_sender.php is equivalent to removing that line of code.

comment:12 westi6 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [6599]) Revert #5007 as it causes more trouble than it solves. Fixes #5273 for trunk.

comment:13 westi6 years ago

  • Milestone changed from 2.5 to 2.3.3
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for 2.3.3 if it happens.

comment:14 in reply to: ↑ 11 ; follow-up: bberndt6 years ago

Replying to lloydbudd:

Replying to bberndt:

None of the workarounds in #5294 worked for me. The no_sender.php plugin DOES appear to fix the problem, however.

That does not programmatically make sense. no_sender.php is equivalent to removing that line of code.

I've confirmed this behavior. I removed the line, disabled the plugin, and still no notification emails.

Put the line back in, enabled the plugin, and I get emails. Removed the line, and left the plugin enabled, and I get emails.

Do I have some other problem, maybe?

comment:15 in reply to: ↑ 14 bberndt6 years ago

Replying to bberndt:

Replying to lloydbudd:

Replying to bberndt:

None of the workarounds in #5294 worked for me. The no_sender.php plugin DOES appear to fix the problem, however.

That does not programmatically make sense. no_sender.php is equivalent to removing that line of code.

I've confirmed this behavior. I removed the line, disabled the plugin, and still no notification emails.

Put the line back in, enabled the plugin, and I get emails. Removed the line, and left the plugin enabled, and I get emails.

Do I have some other problem, maybe?

My hosting provider seems to have found something in my case. See #5647

comment:16 ryan6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [6706]) Revert #5007 as it causes more trouble than it solves. Fixes #5273 for 2.3

comment:17 lexhair6 years ago

This 'defect' has appeared in my 2.3.3 install. Now I didn't experience it prior to 2.3.3 so it's unlikely the revert caused my problem so I don't think reopening the ticket is appropriate. Link to the support forums follows:

http://wordpress.org/support/topic/130205/page/2?replies=57

Note: See TracTickets for help on using tickets.